summaryrefslogtreecommitdiff
path: root/recipes/eggdbus/files/marshal.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2010-01-22 00:36:54 +0000
committerGraeme Gregory <dp@xora.org.uk>2010-01-22 00:38:59 +0000
commita4cebe9f1d505fbcc040ba67a927e543125f5854 (patch)
tree479788107b38323ae53a940550842e572a2ee771 /recipes/eggdbus/files/marshal.patch
parent5cc04010e70378484efe549b30b411f840e825f5 (diff)
eggdbus_0.6.bb : add this new recipe which is gobject bindings for dbus
This is required by the newer policykit packages which I am working on pulling into OE.
Diffstat (limited to 'recipes/eggdbus/files/marshal.patch')
-rw-r--r--recipes/eggdbus/files/marshal.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/eggdbus/files/marshal.patch b/recipes/eggdbus/files/marshal.patch
new file mode 100644
index 0000000000..2b2cb4985b
--- /dev/null
+++ b/recipes/eggdbus/files/marshal.patch
@@ -0,0 +1,26 @@
+Index: eggdbus-0.6/src/eggdbus/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/src/eggdbus/Makefile.am
++++ eggdbus-0.6/src/eggdbus/Makefile.am
+@@ -130,7 +130,7 @@ BUILT_SOURCES = \
+ $(NULL)
+
+ eggdbus-built-sources.stamp : eggdbus-binding-tool Makefile.am org.freedesktop.DBus.xml org.freedesktop.DBus.Peer.xml org.freedesktop.DBus.Properties.xml org.freedesktop.DBus.Introspectable.xml eggdbus-glib-genmarshal
+- EGG_DBUS_GENMARSHAL=$(top_builddir)/src/eggdbus/eggdbus-glib-genmarshal $(top_builddir)/src/eggdbus/eggdbus-binding-tool \
++ EGG_DBUS_GENMARSHAL=eggdbus-glib-genmarshal eggdbus-binding-tool \
+ --namespace EggDBus \
+ --dbus-namespace org.freedesktop.DBus \
+ --interfaces-only \
+Index: eggdbus-0.6/src/tests/Makefile.am
+===================================================================
+--- eggdbus-0.6.orig/src/tests/Makefile.am
++++ eggdbus-0.6/src/tests/Makefile.am
+@@ -25,7 +25,7 @@ BUILT_SOURCES = \
+ $(NULL)
+
+ test-built-sources.stamp : Makefile.am $(top_builddir)/src/eggdbus/eggdbus-binding-tool com.example.Frob.xml com.example.Tweak.xml com.example.Twiddle.xml
+- EGG_DBUS_GENMARSHAL=$(top_builddir)/src/eggdbus/eggdbus-glib-genmarshal $(top_builddir)/src/eggdbus/eggdbus-binding-tool \
++ EGG_DBUS_GENMARSHAL=eggdbus-glib-genmarshal eggdbus-binding-tool \
+ --namespace "Test" \
+ --dbus-namespace "com.example" \
+ --include-header testtypes.h \