summaryrefslogtreecommitdiff
path: root/recipes/dvsdk/ti-lpm-module_2.23.1.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-16 16:42:27 +0100
committerPhil Blundell <philb@gnu.org>2009-06-16 16:42:27 +0100
commit4e0f69867535f4a93e0af3ffb26336e1a3a85f65 (patch)
treec4e1f45e61cc101564036737ba3518de74c5ed01 /recipes/dvsdk/ti-lpm-module_2.23.1.bb
parent73bdf9cc0c931f8d49596bc89ceb632e2e464d84 (diff)
parente2b659db223fca8b5e3e8c3241da0d8a3399f25e (diff)
Merge branch 'org.openembedded.dev' of git@new.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/dvsdk/ti-lpm-module_2.23.1.bb')
-rw-r--r--recipes/dvsdk/ti-lpm-module_2.23.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-lpm-module_2.23.1.bb b/recipes/dvsdk/ti-lpm-module_2.23.1.bb
new file mode 100644
index 0000000000..790b7f99d0
--- /dev/null
+++ b/recipes/dvsdk/ti-lpm-module_2.23.1.bb
@@ -0,0 +1,61 @@
+DESCRIPTION = "LPM module for TI OMAP3 processors"
+
+inherit module
+# compile and run time dependencies
+DEPENDS = " virtual/kernel perl-native ti-dsplink-module"
+
+PR = "r9"
+PV = "2231"
+
+SRC_URI = "http://install.source.dir.com/codec_engine_2_23_01.tar.gz "
+
+# Set the source directory
+S = "${WORKDIR}/codec_engine_2_23_01"
+
+export DSPLINK="${S}/cetools/packages/dsplink"
+
+LPMDSPPOWERSOC ?= "omap3530"
+LPMDSPPOWERSOC_omap3evm ?= "omap3530"
+LPMDSPPOWERSOC_beagleboard ?= "omap3530"
+
+do_compile () {
+ # TODO :: KERNEL_CC, etc need replacing with user CC
+ # TODO :: Need to understand why OBJDUMP is required for kernel module
+ # Unset these since LDFLAGS gets picked up and used incorrectly.... need
+ # investigation
+
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+ cd ${S}/cetools/packages/ti/bios/power/modules/${LPMDSPPOWERSOC}/lpm
+ make \
+ DSPLINK_REPO="${DSPLINK}/.." \
+ LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" \
+ MVTOOL_PREFIX="${TARGET_PREFIX}" \
+ clean default
+}
+
+do_install () {
+
+ # LPM/CMEM/SDMA drivers - kernel modules
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/cetools/packages/ti/bios/power/modules/${LPMDSPPOWERSOC}/lpm/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+}
+
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*lpm*ko"
+RDEPENDS += " ti-dsplink-module"
+