summaryrefslogtreecommitdiff
path: root/recipes/dvsdk/ti-dm355mm-module_1.13.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-16 16:08:09 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-16 16:08:09 +0200
commit8687813463bc7c9f37349000f75cfc0967da8458 (patch)
treeeb550c22da7a2d9b35c64aee09172bd9d117c098 /recipes/dvsdk/ti-dm355mm-module_1.13.bb
parentd895433b6c50e46edd9a75ed512455513f8e00df (diff)
dvsdk: sync with TI overlay (http://arago-project.org/git/people/?p=brijesh/arago-dvsdk.git;a=summary)
* cleanups will follow later
Diffstat (limited to 'recipes/dvsdk/ti-dm355mm-module_1.13.bb')
-rw-r--r--recipes/dvsdk/ti-dm355mm-module_1.13.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-dm355mm-module_1.13.bb b/recipes/dvsdk/ti-dm355mm-module_1.13.bb
new file mode 100644
index 0000000000..cb8c39d021
--- /dev/null
+++ b/recipes/dvsdk/ti-dm355mm-module_1.13.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "User space DMA module for DM355"
+
+require ti-codec-combo-dm355.inc
+inherit module
+# compile and run time dependencies
+DEPENDS = "virtual/kernel perl-native"
+RDEPENDS = "update-modules"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/dvsdk/codecs/dm355_codecs_setuplinux_1_13_000.bin \
+ file://dm355mm_1_30.patch;patch=1 \
+ "
+S = "${WORKDIR}/dm355_codecs_1_13_000"
+BINFILE="dm355_codecs_setuplinux_1_13_000.bin"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "113"
+PR = "r15"
+
+do_configure() {
+ find ${S} -name "*.ko" -exec rm {} \; || true
+ sed -i -e s:include:#include:g ${S}/dm355mm/Rules.make
+}
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+ cd ${S}/dm355mm/module
+ make \
+ LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" \
+ MVTOOL_PREFIX="${TARGET_PREFIX}";
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/dm355mm/module/dm350mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/dm350mmap.ko"
+
+