summaryrefslogtreecommitdiff
path: root/recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-21 12:43:24 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-21 12:43:24 +0200
commit04d8917f4ce8bd97882c3731fbf47aef467f0fc0 (patch)
tree125b94628f585d25212916a6741e4f1b0d5ff14b /recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb
parente71f23a8ef42b469829a88accb4988bce61aace5 (diff)
dvsdk: sync with TI overlay, but change a few things:
* fix toolchain paths to work with internal toolchains * start installing to ${datadir} again * use MACHINE_KERNEL_PR for kernel modules * and more fixes
Diffstat (limited to 'recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb')
-rw-r--r--recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb b/recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb
new file mode 100644
index 0000000000..04f946bc19
--- /dev/null
+++ b/recipes/dvsdk/ti-codec-combo-dm6446_2.05.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "DM6446 Codec Combo 2.05"
+
+# Should be replaced with real http URL, but for now create codec combo tar from DVSDK installation.
+SRC_URI = "http://install.source.dir.com/dm6446_dvsdk_combos_2_05.tar.gz"
+
+S = "${WORKDIR}/dm6446_dvsdk_combos_2_05"
+
+# Yes, the xdc stuff still breaks with a '.' in PWD
+PV = "205"
+PR = "r11"
+
+installdir = "${datadir}/ti"
+do_compile() {
+ echo "do nothing"
+}
+
+do_install () {
+ install -d ${D}/${installdir}/codec-combo
+ cd ${S}
+ for file in `find . -name *.x64P`; do
+ cp ${file} ${D}/${installdir}/codec-combo
+ done
+}
+
+do_stage() {
+ install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}
+ cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/${PN}/
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILES_${PN} = "/${installdir}/codec-combo/*"
+