summaryrefslogtreecommitdiff
path: root/recipes/curl/curl-common.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-04-07 13:24:55 +0000
committerDenys Dmytriyenko <denis@denix.org>2009-04-09 22:56:43 -0400
commit5c69bdef4ca0d8413477db32cc82b82395806504 (patch)
treea14223e0fef041c8c63b5179eb6f41aaa3db3e3b /recipes/curl/curl-common.inc
parentcda3a2428521adac4749fc0c71afcedd50a9307a (diff)
curl: move PACKAGES and FILES_* from the .inc file
this resolves the lockfile() trying to access the wrong directory when building sdk version after target one was built Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/curl/curl-common.inc')
-rw-r--r--recipes/curl/curl-common.inc57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/curl/curl-common.inc b/recipes/curl/curl-common.inc
new file mode 100644
index 0000000000..ce4f5f2a8e
--- /dev/null
+++ b/recipes/curl/curl-common.inc
@@ -0,0 +1,57 @@
+DESCRIPTION = "Command line tool and library for client-side URL transfers."
+LICENSE = "MIT"
+SECTION = "console/network"
+
+SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
+ file://pkgconfig_fix.patch;patch=1"
+S = "${WORKDIR}/curl-${PV}"
+
+CURL_FEATURES ?= "zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp"
+# other allowed features: ipv6, ares
+
+inherit autotools pkgconfig binconfig
+
+EXTRA_OECONF = " \
+ --without-libssh2 \
+ --with-random=/dev/urandom \
+ --without-libidn \
+ --without-ssl \
+ "
+
+python __anonymous() {
+ f = bb.data.getVar("CURL_FEATURES", d, True).split(",")
+ oeconf = bb.data.getVar("EXTRA_OECONF", d, False)
+ deps = bb.data.getVar("DEPENDS", d, False).split()
+ for x in [ 'cookies', 'crypto-auth', 'dict', 'file', 'ftp', 'http', 'telnet', 'tftp', 'ipv6' ]:
+ if x in f:
+ oeconf += " --enable-%s" % x
+ else:
+ oeconf += " --disable-%s" % x
+ if 'zlib' in f:
+ oeconf += " --with-zlib=${STAGING_LIBDIR}/../"
+ deps.append("zlib")
+ else:
+ oeconf += " --without-zlib"
+ if 'gnutls' in f:
+ oeconf += " --with-gnutls=${STAGING_BINDIR_CROSS}"
+ deps.append("gnutls")
+ else:
+ oeconf += " --without-gnutls"
+ if 'ares' in f:
+ oeconf += " --enable-ares"
+ deps.append("c-ares")
+ else:
+ oeconf += " --disable-ares"
+ bb.data.setVar('EXTRA_OECONF', oeconf, d)
+ bb.data.setVar('DEPENDS', " ".join(deps), d)
+}
+
+do_configure_prepend() {
+ sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/curl
+ install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/
+ oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR}
+}