summaryrefslogtreecommitdiff
path: root/recipes/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/console-tools/console-tools_0.3.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/console-tools/console-tools_0.3.2.bb')
-rw-r--r--recipes/console-tools/console-tools_0.3.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes/console-tools/console-tools_0.3.2.bb b/recipes/console-tools/console-tools_0.3.2.bb
new file mode 100644
index 0000000000..9e48c2c572
--- /dev/null
+++ b/recipes/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,51 @@
+SECTION = "base"
+LICENSE = "GPL"
+DESCRIPTION = "Allows you to set-up and manipulate the Linux console."
+PR = "r4"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
+ file://codepage.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://compile.patch;patch=1 \
+ file://kbdrate.patch;patch=1 \
+ file://uclibc-fileno.patch;patch=1 \
+ file://config/*.m4"
+
+export SUBDIRS = "fontfiletools vttools kbdtools screenfonttools contrib \
+ examples po intl compat"
+
+acpaths = "-I config"
+do_configure_prepend () {
+ mkdir -p config
+ cp ${WORKDIR}/config/*.m4 config/
+}
+
+do_compile () {
+ oe_runmake -C lib
+ oe_runmake 'SUBDIRS=${SUBDIRS}'
+}
+
+inherit autotools
+
+do_install () {
+ autotools_do_install
+ mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
+ mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
+ mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+ mv ${D}${bindir}/showkey ${D}${bindir}/showkey.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
+ update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
+ update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+ update-alternatives --install ${bindir}/showkey showkey showkey.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove chvt chvt.${PN}
+ update-alternatives --remove deallocvt deallocvt.${PN}
+ update-alternatives --remove openvt openvt.${PN}
+ update-alternatives --remove showkey showkey.${PN}
+}
+