summaryrefslogtreecommitdiff
path: root/recipes/compcache/compcache_0.6.bb
diff options
context:
space:
mode:
authorMing Chow 周明 <chow.ming@linuxbj.com>2009-08-22 07:38:49 +0000
committerKhem Raj <raj.khem@gmail.com>2009-08-31 15:55:57 -0700
commitccd18852f3dcba528bdfdf557ba9967f64625c11 (patch)
treee92399c97ab9c3966d08879a2b78814028cfa7f0 /recipes/compcache/compcache_0.6.bb
parent5e51870a3ebcba57fb47fd221b7d79594e9d3b73 (diff)
compcache: Add version 0.5+0.6pre3 and version 0.6
* compcache creates RAM based block device (named ramzswap) which acts as swap disk. Pages swapped to this disk are compressed and stored in memory itself. * Compressing pages and keeping them in RAM virtually increases its capacity. This allows more applications to fit in given amount of memory. * added modules_install target in top Makefile to fit the automatically modules build process * added KERNELDIR variable to make 2.6 style KBUILD system work * modified the Makefile for rzscontrol tool to use cross toolchain instead of local gcc Signed-off-by: Ming Zhou <chow.ming@linuxbj.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/compcache/compcache_0.6.bb')
-rw-r--r--recipes/compcache/compcache_0.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/compcache/compcache_0.6.bb b/recipes/compcache/compcache_0.6.bb
new file mode 100644
index 0000000000..a24574c703
--- /dev/null
+++ b/recipes/compcache/compcache_0.6.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "http://code.google.com/p/compcache"
+DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://compcache.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://003-compcache-0.6-KERNELDIR.patch;patch=1 \
+ file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
+ file://002-compcache-modules-install.patch;patch=1 \
+ "
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
+
+FILES_kernel-module-compcache = ${FILES_compcache}
+FILES_compcache-utils = "${bindir}/rzscontrol"
+FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
+FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
+
+do_install_prepend() {
+ mkdir -p ${D}${bindir}
+ mkdir -p ${D}${mandir}/man1
+ install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
+ install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
+}
+