summaryrefslogtreecommitdiff
path: root/recipes/cmake/cmake_2.6.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-28 11:19:12 +0200
committerKoen Kooi <koen@openembedded.org>2010-03-28 11:19:12 +0200
commitef9803f0e5fa66c7741263285e6d4904960e27d9 (patch)
tree698f598ee4c82b48975adae303b80d4cc663070c /recipes/cmake/cmake_2.6.4.bb
parenta69ae9db060d0930c24d6b6c686ba589375c4bee (diff)
cmake 2.6.4: convert native to new style staging and add (currenly non working) 2.6.4 for target
* does anyone know how pass only 3 vars to cmakecache instead everything?
Diffstat (limited to 'recipes/cmake/cmake_2.6.4.bb')
-rw-r--r--recipes/cmake/cmake_2.6.4.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes/cmake/cmake_2.6.4.bb b/recipes/cmake/cmake_2.6.4.bb
new file mode 100644
index 0000000000..53a4c13d2e
--- /dev/null
+++ b/recipes/cmake/cmake_2.6.4.bb
@@ -0,0 +1,8 @@
+require cmake.inc
+
+inherit cmake
+
+do_configure_append() {
+ sed -i -e 's,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=1,HAVE_GLIBC_STRERROR_R__TRYRUN_OUTPUT-ADVANCED:INTERNAL=0,' CMakeCache.txt
+}
+