summaryrefslogtreecommitdiff
path: root/recipes/busybox/busybox_1.17.1.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 17:19:14 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 17:21:47 -0700
commite325cc7b38be32e6352f19b4712f96144be3ffe5 (patch)
tree3ae50234832ad1ae33fd7f08f40a8b5ef9db7a81 /recipes/busybox/busybox_1.17.1.bb
parent8925db69ff1d5699b7fce8fb072d4d500232da68 (diff)
busybox: Add 1.17.1, D_P = -1 for all for now
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/busybox/busybox_1.17.1.bb')
-rw-r--r--recipes/busybox/busybox_1.17.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes/busybox/busybox_1.17.1.bb b/recipes/busybox/busybox_1.17.1.bb
new file mode 100644
index 0000000000..5a475b2ca7
--- /dev/null
+++ b/recipes/busybox/busybox_1.17.1.bb
@@ -0,0 +1,61 @@
+require busybox.inc
+PR = "${INC_PR}"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "\
+ http://www.busybox.net/downloads/busybox-${PV}.tar.bz2 \
+ file://fdisk_nios2.patch \
+ \
+ file://udhcpscript.patch \
+ file://udhcpc-fix-nfsroot.patch \
+ file://B921600.patch \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
+# file://0000-wget-no-check-certificate.patch \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script file://simple.script \
+ file://hwclock.sh \
+ file://hwclock-default \
+ file://mount.busybox \
+ file://mountall \
+ file://syslog \
+ file://syslog.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://mdev \
+ file://mdev.conf \
+"
+
+SRC_URI[md5sum] = "c7fe7533b7fc4018b0b49a05ee0ee601"
+SRC_URI[sha256sum] = "bf9177810d7e151b0e662477c33b9afd062570e6298ec46f2a8397a6a839d164"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure_prepend () {
+ if [ "${TARGET_ARCH}" = "avr32" ] ; then
+ sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
+ fi
+}
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/mdev
+ install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
+ install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
+
+ if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
+ install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}${sysconfdir}/init.d/
+ fi
+
+ if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
+ install -d ${D}${sysconfdir}/udhcpc.d
+ install -d ${D}${datadir}/udhcpc
+ install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
+ install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
+ fi
+}