summaryrefslogtreecommitdiff
path: root/recipes/boa/boa_0.94.13.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/boa/boa_0.94.13.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/boa/boa_0.94.13.bb')
-rw-r--r--recipes/boa/boa_0.94.13.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/boa/boa_0.94.13.bb b/recipes/boa/boa_0.94.13.bb
new file mode 100644
index 0000000000..342dce97bd
--- /dev/null
+++ b/recipes/boa/boa_0.94.13.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Lightweight and High Performance WebServer"
+SECTION = "console/network"
+LICENSE = "GPL"
+RDEPENDS = "mime-support"
+RPROVIDES = "httpd"
+PR = "r3"
+
+SRC_URI = "http://www.boa.org/boa-${PV}.tar.gz \
+ file://cgi.patch;patch=1;pnum=2 \
+ file://debian-patch.diff;patch=1;pnum=2 \
+ file://boa.conf \
+ file://boa.init"
+
+S = "${WORKDIR}/boa-${PV}/src"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "boa"
+INITSCRIPT_PARAMS = "defaults 20"
+
+CFLAGS_append = " -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
+#CFLAGS_append = " -DSERVER_ROOT=..."
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${libdir}/${PN}
+ install -m 0755 boa ${D}${sbindir}
+ install -m 0755 boa_indexer ${D}${libdir}/${PN}
+
+ install -d ${D}${sysconfdir}/${PN}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0640 ${WORKDIR}/boa.conf ${D}${sysconfdir}/${PN}
+ install -m 0755 ${WORKDIR}/boa.init ${D}${sysconfdir}/init.d/boa
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/../docs/boa.8 ${D}${mandir}/man8
+}