summaryrefslogtreecommitdiff
path: root/recipes/balsa/balsa_2.4.1.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-08-12 19:43:27 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-08-12 19:43:27 +0000
commit99fe4c90c40584d0d394b497243d789724b1d95a (patch)
tree94a4eb7fc9f7fb84fb8dfcd2c713359b715638ad /recipes/balsa/balsa_2.4.1.bb
parentb5f769c7e06a623c8ac400ead0d0e7e10a78ee7f (diff)
balsa: Updated to version 2.4.1. Disabled broken touchscreen mode.
Diffstat (limited to 'recipes/balsa/balsa_2.4.1.bb')
-rw-r--r--recipes/balsa/balsa_2.4.1.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes/balsa/balsa_2.4.1.bb b/recipes/balsa/balsa_2.4.1.bb
new file mode 100644
index 0000000000..c66ec5a2bc
--- /dev/null
+++ b/recipes/balsa/balsa_2.4.1.bb
@@ -0,0 +1,83 @@
+DESCRIPTION = "Robust and configurable e-mail client for GNOME"
+HOMEPAGE = "http://pawsa.fedorapeople.org/balsa/"
+SECTION = "x11/network"
+LICENSE = "GPL"
+SRC_URI = "http://pawsa.fedorapeople.org/balsa/${P}.tar.bz2"
+
+DEPENDS = "glib-2.0 libgmime-2.4 gtk+ intltool-native libesmtp libxml-parser-perl-native"
+# FIXME: It is possible to build several variants of balsa: lite (SSL, gqlite/GPE, maybe HTML),
+# standard (GNOME, spell checking, HTML), full (Kerberos, LDAP, PGP, Rubrica, X-Face)
+
+# Options for regular expressions are: NONE (POSIX) glib-2.0 (GRegex) libpcre (PCRE)
+DEPENDS += ""
+
+# Options for remote activation are: libbonobo libunique
+DEPENDS += "libunique"
+
+# Options for HTML view are: gtkhtml-2.0 gtkhtml-3.0 webkit-gtk NONE
+DEPENDS += "webkit-gtk"
+
+# Optional dependencies (missing in OE): Spell checking
+#DEPENDS += "gtkspell"
+
+# Optional dependencies: SSL support:
+DEPENDS += "openssl"
+
+# Optional dependencies: GPE addressbook:
+DEPENDS += "sqlite"
+
+# Optional dependencies: GNOME:
+DEPENDS += "gconf libgnome libgnomeui"
+#DEPENDS += "gnome-keyring"
+
+# Optional dependencies: PGP support:
+#DEPENDS += "gpgme"
+
+# Optional dependencies: view source:
+#DEPENDS += "gtksourceview2"
+
+# Optional dependencies: LDAP:
+#DEPENDS += "openldap"
+
+# Options for optional Kerberos 5: heimdal (not in OE) krb5
+#DEPENDS += "krb5"
+
+# Optional dependencies: Rubrica addressbook:
+#DEPENDS += "libxml2"
+
+# Optional dependencies (not yet in OE): X-Face support:
+#DEPENDS += "compface"
+
+# Optional dependencies: sound support:
+#DEPENDS += "libcanberra"
+
+# FIXME: doc build requires docbook4 and gnome-doc-utils
+
+inherit autotools
+
+EXTRA_OECONF="--with-ssl \
+ --without-gnome \
+ --disable-scrollkeeper \
+ --enable-smime \
+ --with-sqlite \
+ --with-ssl \
+ --with-webkit \
+ --with-unique \
+ --without-gtkspell \
+"
+# Broken (does not compile, crashes after symbol fix):
+# --enable-touch-ui \
+# Not enabled:
+# --with-gtkspell \
+# --with-gpgme \
+# --with-gtksourceview \
+# --with-rubrica \
+# --with-gss \
+# --with-ldap \
+# --with-compface \
+# --with-canberra \
+
+do_configure_prepend() {
+ # aclocal seems to insist on looking in here. Make sure it exists.
+ mkdir -p ${S}/m4
+}