summaryrefslogtreecommitdiff
path: root/recipes/anthy/anthy_9100e.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/anthy/anthy_9100e.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/anthy/anthy_9100e.bb')
-rw-r--r--recipes/anthy/anthy_9100e.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/anthy/anthy_9100e.bb b/recipes/anthy/anthy_9100e.bb
new file mode 100644
index 0000000000..3b4b930211
--- /dev/null
+++ b/recipes/anthy/anthy_9100e.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "A Japanese input method"
+DESCRIPTION_anthy = "A Japanese input method (backend, dictionary and utility)"
+DESCRIPTION_libanthy0 = "Anthy runtime library"
+DESCRIPTION_libanthy-dev = "Anthy static library, headers and documets for developers"
+AUTHOR = "Anthy Developers <anthy-dev@lists.sourceforge.jp>"
+HOMEPAGE = "http://anthy.sourceforge.jp"
+SECTION = "inputmethods"
+SECTION_libanthy0 = "libs/inputmethods"
+SECTION_libanthy-dev = "devel/libs"
+LICENSE = "GPL"
+DEPENDS = "anthy-native"
+PR = "r3"
+
+SRC_URI = "http://osdn.dl.sourceforge.jp/anthy/29142/anthy-9100e.tar.gz \
+ file://not_build_elc.patch;patch=1 \
+ file://2ch_t.patch;patch=1 \
+ file://native-helpers.patch;patch=1"
+
+inherit autotools pkgconfig
+
+# gettext
+
+LEAD_SONAME = "libanthy.so.0"
+RDEPENDS_anthy = "libanthy0"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES += "${PN}-el libanthy0 libanthy-dev"
+FILES_${PN}-dbg += "${libdir}/.debug"
+FILES_libanthy0 = "${libdir}/libanthy.so.* \
+ ${libdir}/libanthydic.so.* \
+ ${libdir}/libanthyinput.so.*"
+FILES_libanthy-dev = "${libdir}/libanthy*.la \
+ ${libdir}/libanthy*.a \
+ ${libdir}/libanthy*.so \
+ ${includedir}/anthy \
+ ${libdir}/pkgconfig/anthy.pc"
+FILES_${PN}-el = "${datadir}/emacs/*"
+FILES_${PN} = "${datadir}/* \
+ ${bindir}/* \
+ ${sysconfdir}/anthy-conf"