summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-05-14 10:37:49 +0000
committerJohn Lee <john_lee@openmoko.org>2008-12-18 23:05:55 +0800
commitfd1aaa7cb993049e1eb3503c5fd932e74b667999 (patch)
tree1c3eca8d935a30b5adea16ad7db8d61c2ccfea06 /packages
parent73f61225efed9f3af1a1f5f3d491aa5e87f2641f (diff)
openmoko-toolchain-scripts: bugfix ${S}, change directory.
* fix ${S} * set PACKAGE_ARCH to "all" * move to openmoko-tools. one less directory.
Diffstat (limited to 'packages')
-rw-r--r--packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb (renamed from packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb)19
1 files changed, 11 insertions, 8 deletions
diff --git a/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb b/packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb
index 60dab56569..e30d66b58a 100644
--- a/packages/openmoko-spaces/openmoko-toolchain-scripts_svn.bb
+++ b/packages/openmoko-tools/openmoko-toolchain-scripts_svn.bb
@@ -2,18 +2,21 @@ DESCRIPTION = "Convenient scripts to be used with openmoko toolchain."
PV = "0.0+svnr${SRCREV}"
PE = "1"
+PR = "r1"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=toolchain-scripts;proto=http"
S = "${WORKDIR}/toolchain-scripts"
-FILES_${PN} = "/bin /scripts /* \
-"
-
do_install () {
- install -d ${D}/doc
- cp -dr ${S}/* ${D}
- find ${D} -name ".svn" | xargs rm -rf
- rm -r ${D}/patches
- cd ${D} ; mv COPYING COPYING.MIT LICENSE README doc ; mv setup-env bin
+ install -d ${D}/${prefix}
+ cp -dr ${S}/* ${D}/${prefix}
+ find ${D} -name ".svn" | xargs rm -rf
+ rm -rf ${D}/${prefix}/patches
}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/*"
+
+inherit sdk