summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-06 10:22:46 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-06 10:22:46 +0100
commitc86e6bf053bdf18dc6864bea25af534ef44fc220 (patch)
tree8969790e7cb17e09ba2ccf3f21d00442c6daad1d /packages
parente9f9ed9628f8fd008e584a98e8683597d0666b09 (diff)
linux omap git: add patch for fix recording on TWL4030 codecs
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/linux-omap/twl-asoc-fix-record.diff34
-rw-r--r--packages/linux/linux-omap_git.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/packages/linux/linux-omap/twl-asoc-fix-record.diff b/packages/linux/linux-omap/twl-asoc-fix-record.diff
new file mode 100644
index 0000000000..9c0ceaa2e0
--- /dev/null
+++ b/packages/linux/linux-omap/twl-asoc-fix-record.diff
@@ -0,0 +1,34 @@
+From linux-omap-owner@vger.kernel.org Sat Dec 06 02:14:21 2008
+Date: Fri, 5 Dec 2008 16:46:34 -0800
+From: "Steve Sakoman" <sakoman@gmail.com>
+To: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>
+Subject: [FYI PATCH] ASOC:TWL4030 Audio capture fix
+
+A couple of folks have noticed an issue with audio capture -- the
+capture result is always silence.
+
+The patch below is a quick fix for those with this issue. There are
+substantial changes to the codec driver that will be trickling down
+from ASoC, and they deal with this issue differently.
+
+So consider this as a bandaid for those who don't want to wait for the
+trickle down :-)
+
+Steve
+
+
+diff --git a/sound/soc/codecs/twl4030.c b/sound/soc/codecs/twl4030.c
+index ee2f0d3..8b4aafb 100644
+--- a/sound/soc/codecs/twl4030.c
++++ b/sound/soc/codecs/twl4030.c
+@@ -45,8 +45,8 @@ static const u8 twl4030_reg[TWL4030_CACHEREGNUM] = {
+ 0xc3, /* REG_OPTION (0x2) */
+ 0x00, /* REG_UNKNOWN (0x3) */
+ 0x00, /* REG_MICBIAS_CTL (0x4) */
+- 0x24, /* REG_ANAMICL (0x5) */
+- 0x04, /* REG_ANAMICR (0x6) */
++ 0x34, /* REG_ANAMICL (0x5) */
++ 0x14, /* REG_ANAMICR (0x6) */
+ 0x0a, /* REG_AVADC_CTL (0x7) */
+ 0x00, /* REG_ADCMICSEL (0x8) */
+ 0x00, /* REG_DIGMIXING (0x9) */
diff --git a/packages/linux/linux-omap_git.bb b/packages/linux/linux-omap_git.bb
index 8aca34a8b3..c0ec324ee8 100644
--- a/packages/linux/linux-omap_git.bb
+++ b/packages/linux/linux-omap_git.bb
@@ -10,7 +10,7 @@ SRCREV = "014ba70469e889ebb74516052c43fd06a419b17b"
PV = "2.6.27+2.6.28-rc7+${PR}+gitr${SRCREV}"
#PV = "2.6.27+${PR}+gitr${SRCREV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"
@@ -38,6 +38,7 @@ SRC_URI_append = " \
file://0009-DSS-Sharp-LS037V7DW01-LCD-Panel-driver.patch;patch=1 \
file://0011-DSS-Support-for-OMAP3-EVM-board.patch;patch=1 \
http://www.bat.org/~tomba/git/0001-DSS-OMAPFB-Check-that-var-pixclock-is-not-zero.patch;patch=1 \
+ file://twl-asoc-fix-record.diff;patch=1 \
"