summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2008-11-24 16:50:22 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2008-11-24 16:50:22 +0100
commitc7d514e3de6cb0ddad3dbc7efd4428b24cd2d144 (patch)
treed6f9519110bbb03b111592d04d52fe9481587ef6 /packages
parent659a8173e83ead481adb7c677403427dd00ec6bf (diff)
u-boot: add mtdparts support for boc01
Diffstat (limited to 'packages')
-rw-r--r--packages/u-boot/u-boot-1.3.2/boc01/001_01_u-boot-1.3.2_SPI.patch16
-rw-r--r--packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-mtdparts.patch10
-rw-r--r--packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch12
-rw-r--r--packages/u-boot/u-boot_1.3.2.bb8
4 files changed, 24 insertions, 22 deletions
diff --git a/packages/u-boot/u-boot-1.3.2/boc01/001_01_u-boot-1.3.2_SPI.patch b/packages/u-boot/u-boot-1.3.2/boc01/001_01_u-boot-1.3.2_SPI.patch
index 36c3b9fe2f..183cf49395 100644
--- a/packages/u-boot/u-boot-1.3.2/boc01/001_01_u-boot-1.3.2_SPI.patch
+++ b/packages/u-boot/u-boot-1.3.2/boc01/001_01_u-boot-1.3.2_SPI.patch
@@ -1,7 +1,7 @@
Index: u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c
===================================================================
---- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-03-09 16:20:02.000000000 +0100
-+++ u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-11-21 15:19:42.000000000 +0100
+--- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-11-24 16:34:21.000000000 +0100
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c 2008-11-24 16:44:59.000000000 +0100
@@ -28,6 +28,7 @@
#endif
#include <pci.h>
@@ -46,18 +46,18 @@ Index: u-boot-1.3.2/board/freescale/mpc8313erdb/mpc8313erdb.c
+
Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
===================================================================
---- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 15:18:35.000000000 +0100
-+++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 15:19:42.000000000 +0100
-@@ -369,6 +369,7 @@
- #define CONFIG_CMD_DATE
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-24 16:44:55.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-24 16:45:26.000000000 +0100
+@@ -370,6 +370,7 @@
#define CONFIG_CMD_PCI
#define CONFIG_CMD_NAND
+ #define CONFIG_CMD_JFFS2
+#define CONFIG_CMD_SPI
#if defined(CFG_RAMBOOT)
#undef CONFIG_CMD_ENV
-@@ -378,6 +379,11 @@
- #define CONFIG_CMDLINE_EDITING 1
+@@ -387,6 +388,11 @@
+ #define MTDPARTS_DEFAULT "mtdparts=physmap-flash.0:384k(uboot),64k(env)"
+/* SPI */
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-mtdparts.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-mtdparts.patch
index 1c7ccbff53..e453d0145c 100644
--- a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-mtdparts.patch
+++ b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-mtdparts.patch
@@ -1,8 +1,8 @@
Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
===================================================================
---- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 15:01:24.000000000 +0100
-+++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 15:01:57.000000000 +0100
-@@ -182,7 +182,7 @@
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-24 16:38:56.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-24 16:38:58.000000000 +0100
+@@ -179,7 +179,7 @@
#define CFG_INIT_SP_OFFSET CFG_GBL_DATA_OFFSET
/* CFG_MONITOR_LEN must be a multiple of CFG_ENV_SECT_SIZE */
@@ -11,7 +11,7 @@ Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
#define CFG_MALLOC_LEN (512 * 1024) /* Reserved for malloc */
/*
-@@ -372,6 +372,7 @@
+@@ -358,6 +358,7 @@
#define CONFIG_CMD_DATE
#define CONFIG_CMD_PCI
#define CONFIG_CMD_NAND
@@ -19,7 +19,7 @@ Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
#if defined(CFG_RAMBOOT)
#undef CONFIG_CMD_ENV
-@@ -380,6 +381,14 @@
+@@ -366,6 +367,14 @@
#define CONFIG_CMDLINE_EDITING 1
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
index cd84565f94..513a3b1242 100644
--- a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
+++ b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
@@ -1,7 +1,7 @@
Index: u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile
===================================================================
---- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/Makefile 2008-03-09 16:20:02.000000000 +0100
-+++ u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile 2008-09-12 18:15:39.000000000 +0200
+--- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/Makefile 2008-11-24 16:39:09.000000000 +0100
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile 2008-11-24 16:39:15.000000000 +0100
@@ -25,7 +25,7 @@
LIB = $(obj)lib$(BOARD).a
@@ -14,7 +14,7 @@ Index: u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile
Index: u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c 2008-09-12 18:15:39.000000000 +0200
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c 2008-11-24 16:39:15.000000000 +0100
@@ -0,0 +1,868 @@
+/*
+ * Copyright (C) Freescale Semiconductor, Inc. 2006.
@@ -886,9 +886,9 @@ Index: u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c
+#endif
Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
===================================================================
---- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-09-12 18:15:39.000000000 +0200
-+++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:15:39.000000000 +0200
-@@ -358,6 +358,7 @@
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-24 16:39:14.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-24 16:39:15.000000000 +0100
+@@ -357,6 +357,7 @@
#define CONFIG_CMD_MII
#define CONFIG_CMD_DATE
#define CONFIG_CMD_PCI
diff --git a/packages/u-boot/u-boot_1.3.2.bb b/packages/u-boot/u-boot_1.3.2.bb
index d7be607f13..8e6befd9cb 100644
--- a/packages/u-boot/u-boot_1.3.2.bb
+++ b/packages/u-boot/u-boot_1.3.2.bb
@@ -2,23 +2,25 @@ require u-boot.inc
DEFAULT_PREFERENCE = "-1"
-PR = "r4"
+PR = "r5"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
SRC_URI_append_mpc8313e-rdb = "\
+ file://mpc8313e-rdb-autoboot.patch;patch=1 \
file://mpc8313e-rdb-nand.patch;patch=1 \
+ file://mpc8313e-rdb-mtdparts.patch;patch=1 \
file://mpc8313e-rdb-eeprom.patch;patch=1 \
file://mpc8313e-rdb-lm75.patch;patch=1 \
file://u-boot-fsl-1.3.0-mpc8313erdb-vsc7385-support.patch;patch=1 \
file://u-boot-fsl-1.3.0-mpc8313erdb-fix-vitesse-7385-firmware.patch;patch=1 \
file://u-boot-fsl-1.3.0-mpc8313erdb-performance-tuning-for-TSEC.patch;patch=1 \
- file://mpc8313e-rdb-autoboot.patch;patch=1 \
- file://mpc8313e-rdb-mtdparts.patch;patch=1 \
"
SRC_URI_append_boc01 = "\
+ file://mpc8313e-rdb-autoboot.patch;patch=1 \
file://mpc8313e-rdb-nand.patch;patch=1 \
+ file://mpc8313e-rdb-mtdparts.patch;patch=1 \
file://mpc8313e-rdb-eeprom.patch;patch=1 \
file://000_01_u-boot-1.3.2_LM73.patch;patch=1 \
file://001_01_u-boot-1.3.2_SPI.patch;patch=1 \