summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-12-01 22:36:52 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-12-01 22:36:52 +0000
commit9da116be59a7a608285a0f16da7e9a31566b5ccb (patch)
treed85f70784fd882aaf30b901e60cdce5c9e48c518 /packages
parent4ecc73daa223da420e273e74cf8eff18a95d4a33 (diff)
parent7181f2f12b9b48fa6666973da0e9c82ea9e57bd7 (diff)
merge of '80401af978389dc31680f5749d9a6b066bbee542'
and 'eb184b297334b4fd07df0787e5149d8be2c97b65'
Diffstat (limited to 'packages')
-rw-r--r--packages/git/git-native_1.5.3.bb4
-rw-r--r--packages/git/git.inc19
-rw-r--r--packages/libtool/libtool-1.5.10/libdir-la2.patch64
-rw-r--r--packages/libtool/libtool-1.5.10/tag1.patch13
-rw-r--r--packages/libtool/libtool-cross_1.5.10.bb17
-rw-r--r--packages/libtool/libtool-native_1.5.10.bb6
-rw-r--r--packages/libtool/libtool_1.5.10.bb5
-rw-r--r--packages/meta/meta-toolchain.bb17
-rw-r--r--packages/shasum/shasum-native.bb3
-rwxr-xr-xpackages/stage-manager/files/stage-manager57
-rw-r--r--packages/stage-manager/stagemanager-native_0.0.1.bb2
-rw-r--r--packages/x11vnc/x11vnc_0.9.3.bb2
12 files changed, 158 insertions, 51 deletions
diff --git a/packages/git/git-native_1.5.3.bb b/packages/git/git-native_1.5.3.bb
new file mode 100644
index 0000000000..935c773c1c
--- /dev/null
+++ b/packages/git/git-native_1.5.3.bb
@@ -0,0 +1,4 @@
+require git.inc
+inherit native
+DEPENDS = "openssl-native curl-native zlib-native expat-native"
+PR = "r1"
diff --git a/packages/git/git.inc b/packages/git/git.inc
new file mode 100644
index 0000000000..7115d44b35
--- /dev/null
+++ b/packages/git/git.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/git-${PV}"
+
+EXTRA_OEMAKE = "NO_TCLTL=1"
+
+inherit autotools
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+
+FILES_${PN} += "${datadir}/git-core"
diff --git a/packages/libtool/libtool-1.5.10/libdir-la2.patch b/packages/libtool/libtool-1.5.10/libdir-la2.patch
new file mode 100644
index 0000000000..0d5d261203
--- /dev/null
+++ b/packages/libtool/libtool-1.5.10/libdir-la2.patch
@@ -0,0 +1,64 @@
+OE changes to installed=no which means we can't run the original test
+and just look in $objdir. We therefore look in both, preferring
+$objdir if it exists - RP 29/11/2007
+
+--- libtool-1.5.10/ltmain.in.orig
++++ libtool-1.5.10/ltmain.in
+@@ -3105,8 +3105,11 @@
+ fi
+ ;;
+ esac
+- if grep "^installed=no" $deplib > /dev/null; then
+- path="$absdir/$objdir"
++# OE changes to installed=no which means we can't run the original test
++# and just look in $objdir. We therefore look in both, preferring
++# $objdir if it exists, see below. - RP 29/11/2007
++# if grep "^installed=no" $deplib > /dev/null; then
++# path="$absdir/$objdir"
+ # This interferes with crosscompilation. -CL
+ # else
+ # eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
+@@ -3117,7 +3120,7 @@
+ # if test "$absdir" != "$libdir"; then
+ # $echo "$modename: warning: \`$deplib' seems to be moved" 1>&2
+ # fi
+- else
++ if ! grep "^installed=no" $deplib > /dev/null; then
+ eval libdir=`${SED} -n -e 's/^libdir=\(.*\)$/\1/p' $deplib`
+ if test -z "$libdir"; then
+ $echo "$modename: \`$deplib' is not a valid libtool archive" 1>&2
+@@ -3138,9 +3141,17 @@
+ for tmp in $deplibrary_names ; do
+ depdepl=$tmp
+ done
+- if test -f "$path/$depdepl" ; then
+- depdepl="$path/$depdepl"
++
++ if test -f "$absdir/$objdir/$depdepl" ; then
++ depdepl="$absdir/$objdir/$depdepl"
++ path="$absdir/$objdir"
++ elif test -f "$absdir/$depdepl" ; then
++ depdepl="$absdir/$depdepl"
++ path="$absdir"
++ else
++ path="$absdir/$objdir"
+ fi
++
+ # do not add paths which are already there
+ case " $newlib_search_path " in
+ *" $path "*) ;;
+@@ -3150,7 +3161,13 @@
+ path=""
+ ;;
+ *)
+- path="-L$path"
++ if test -d "$absdir/$objdir" ; then
++ path="-L$absdir/$objdir"
++ elif test -d "$absdir" ; then
++ path="-L$absdir"
++ else
++ path="-L$absdir/$objdir"
++ fi
+ ;;
+ esac
+ ;;
diff --git a/packages/libtool/libtool-1.5.10/tag1.patch b/packages/libtool/libtool-1.5.10/tag1.patch
deleted file mode 100644
index 6fefd6266d..0000000000
--- a/packages/libtool/libtool-1.5.10/tag1.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: libtool-1.5.10/libltdl/ltmain.sh
-===================================================================
---- libtool-1.5.10.orig/libltdl/ltmain.sh 2004-09-19 13:34:44.000000000 +0100
-+++ libtool-1.5.10/libltdl/ltmain.sh 2006-05-25 15:28:39.000000000 +0100
-@@ -232,7 +232,7 @@
- if test -z "$tagname"; then
- $echo "$modename: unable to infer tagged configuration"
- $echo "$modename: specify a tag with \`--tag'" 1>&2
-- exit $EXIT_FAILURE
-+# exit $EXIT_FAILURE
- # else
- # $echo "$modename: using $tagname tagged configuration"
- fi
diff --git a/packages/libtool/libtool-cross_1.5.10.bb b/packages/libtool/libtool-cross_1.5.10.bb
index 4c1b7c2e1f..5f15c56a97 100644
--- a/packages/libtool/libtool-cross_1.5.10.bb
+++ b/packages/libtool/libtool-cross_1.5.10.bb
@@ -1,14 +1,17 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r6"
+PR = "r9"
PACKAGES = ""
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
+ file://libdir-la2.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
- file://tag1.patch;patch=1 \
- file://install-path-check.patch;patch=1"
+ file://install-path-check.patch;patch=1 \
+ file://nmedit_fix.patch;patch=1 \
+ file://nousrlib.patch;patch=1"
+
S = "${WORKDIR}/libtool-${PV}"
prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
@@ -16,7 +19,13 @@ exec_prefix = "${STAGING_DIR_NATIVE}${layout_exec_prefix}"
bindir = "${STAGING_BINDIR_NATIVE}"
do_compile () {
- :
+ rm -f ltmain.shT
+ date=`/bin/sh ./mkstamp < ./ChangeLog` && \
+ sed -e 's/@''PACKAGE@/libtool/' -e 's/@''VERSION@/1.5.10/' \
+ -e "s%@""TIMESTAMP@%$date%" ./ltmain.in > ltmain.shT
+ mv -f ltmain.shT ltmain.sh || \
+ (rm -f ltmain.sh && cp ltmain.shT ltmain.sh && rm -f ltmain.shT)
+ cp ltmain.sh ./libltdl/
}
do_stage () {
diff --git a/packages/libtool/libtool-native_1.5.10.bb b/packages/libtool/libtool-native_1.5.10.bb
index 2780ef64ff..e21a20b85d 100644
--- a/packages/libtool/libtool-native_1.5.10.bb
+++ b/packages/libtool/libtool-native_1.5.10.bb
@@ -1,14 +1,16 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r6"
+PR = "r9"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
+ file://libdir-la2.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
- file://tag1.patch;patch=1 \
file://install-path-check.patch;patch=1 \
+ file://nousrlib.patch;patch=1 \
file://rpath-control.patch;patch=1"
+
S = "${WORKDIR}/libtool-${PV}"
inherit native
diff --git a/packages/libtool/libtool_1.5.10.bb b/packages/libtool/libtool_1.5.10.bb
index 20929a7fa2..35cebfa5c2 100644
--- a/packages/libtool/libtool_1.5.10.bb
+++ b/packages/libtool/libtool_1.5.10.bb
@@ -5,7 +5,7 @@ libraries) behind a consistent interface."
HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
LICENSE = "GPL"
SECTION = "devel"
-PR = "r3"
+PR = "r5"
SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
file://autotools.patch;patch=1 \
@@ -13,10 +13,11 @@ SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
file://3figures.patch;patch=1"
S = "${WORKDIR}/libtool-${PV}"
-PACKAGES = "libltdl libltdl-dev ${PN}"
+PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
FILES_${PN} += "${datadir}/aclocal*"
FILES_libltdl = "${libdir}/libltdl.so.*"
FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
+FILES_libltdl-dbg = "${libdir}/.debug/"
inherit autotools
diff --git a/packages/meta/meta-toolchain.bb b/packages/meta/meta-toolchain.bb
index 92fded00af..8f366001e1 100644
--- a/packages/meta/meta-toolchain.bb
+++ b/packages/meta/meta-toolchain.bb
@@ -62,18 +62,18 @@ do_populate_sdk() {
mv ${SDK_OUTPUT}/usr/lib/ipkg/status ${SDK_OUTPUT}/${prefix}/package-status-host
rm -Rf ${SDK_OUTPUT}/usr/lib
- # extract and store ipks, pkgdata, pkgmaps and shlibs data
+ # extract and store ipks, pkgdata and shlibs data
target_pkgs=`cat ${SDK_OUTPUT}/${prefix}/package-status | grep Package: | cut -f 2 -d ' '`
mkdir -p ${SDK_OUTPUT}/${prefix}/ipk/
mkdir -p ${SDK_OUTPUT}/${prefix}/pkgdata/runtime/
- mkdir -p ${SDK_OUTPUT}/${prefix}/pkgmaps/debian/
mkdir -p ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/shlibs/
for pkg in $target_pkgs ; do
for arch in $revipkgarchs; do
- if [ -e ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk ]; then
- echo "Found ${DEPLOY_DIR_IPK}/$arch/${pkg}_$arch.ipk"
- cp ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk ${SDK_OUTPUT}/${prefix}/ipk/
- orig_pkg=`ipkg-list-fields ${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk | grep OE: | cut -d ' ' -f2`
+ pkgnames=${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk
+ if [ -e $pkgnames ]; then
+ echo "Found $pkgnames"
+ cp $pkgnames ${SDK_OUTPUT}/${prefix}/ipk/
+ orig_pkg=`ipkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
mkdir -p ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/runtime
cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/
@@ -83,9 +83,6 @@ do_populate_sdk() {
if [ -e ${STAGING_DIR}/pkgdata/$pkg_subdir/runtime/$subpkg.packaged ];then
cp ${STAGING_DIR}/pkgdata/$pkg_subdir/runtime/$subpkg.packaged ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/runtime/
fi
- if [ -e ${STAGING_DIR}/pkgmaps/debian/$subpkg ]; then
- cp ${STAGING_DIR}/pkgmaps/debian/$subpkg ${SDK_OUTPUT}/${prefix}/pkgmaps/debian/
- fi
if [ -e ${STAGING_DIR_TARGET}/shlibs/$subpkg.list ]; then
cp ${STAGING_DIR_TARGET}/shlibs/$subpkg.* ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/shlibs/
fi
@@ -97,6 +94,8 @@ do_populate_sdk() {
# add missing link to libgcc_s.so.1
# libgcc-dev should be responsible for that, but it's not getting built
+ # RP: it gets smashed up depending on the order that gcc, gcc-cross and
+ # gcc-cross-sdk get built :( (30/11/07)
ln -sf libgcc_s.so.1 ${SDK_OUTPUT}/${prefix}/${TARGET_SYS}/lib/libgcc_s.so
# remove unwanted executables
diff --git a/packages/shasum/shasum-native.bb b/packages/shasum/shasum-native.bb
index 2b9dd9a09d..a28d5ac967 100644
--- a/packages/shasum/shasum-native.bb
+++ b/packages/shasum/shasum-native.bb
@@ -6,6 +6,7 @@ INHIBIT_DEFAULT_DEPS = "1"
PATCHTOOL = "patch"
do_fetch[depends] = ""
-do_populate_staging() {
+do_stage() {
+ install -d ${STAGING_BINDIR}
install ${S}/oe_sha256sum ${STAGING_BINDIR}
}
diff --git a/packages/stage-manager/files/stage-manager b/packages/stage-manager/files/stage-manager
index c5b6d17a56..35453992f4 100755
--- a/packages/stage-manager/files/stage-manager
+++ b/packages/stage-manager/files/stage-manager
@@ -1,6 +1,6 @@
#!/usr/bin/env python
-# Copyright (C) 2006 Richard Purdie
+# Copyright (C) 2006-2007 Richard Purdie
#
# This program is free software; you can redistribute it and/or modify it under
# the terms of the GNU General Public License version 2 as published by the Free
@@ -79,33 +79,54 @@ if __name__ == "__main__":
found = False
+ def updateCache(path, fstamp):
+ cache[path] = {}
+ cache[path]['ts'] = fstamp[stat.ST_MTIME]
+ cache[path]['size'] = fstamp[stat.ST_SIZE]
+ found = True
+
+ def copyfile(path):
+ if options.copydir:
+ copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
+ mkdirhier(os.path.split(copypath)[0])
+ os.system("cp -dp " + path + " " + copypath)
+
+ def copydir(path, fstamp):
+ if options.copydir:
+ copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
+ if os.path.islink(path):
+ os.symlink(os.readlink(path), copypath)
+ else:
+ mkdirhier(copypath)
+ os.utime(copypath, (fstamp[stat.ST_ATIME], fstamp[stat.ST_MTIME]))
+
for root, dirs, files in os.walk(options.parentdir):
for f in files:
path = os.path.join(root, f)
if not os.access(path, os.R_OK):
continue
- fstamp = os.stat(path)
+ fstamp = os.lstat(path)
if path not in cache:
print "new file %s" % path
- cache[path] = {}
- cache[path]['ts'] = fstamp[stat.ST_MTIME]
- cache[path]['size'] = fstamp[stat.ST_SIZE]
- if options.copydir:
- copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
- mkdirhier(os.path.split(copypath)[0])
- os.system("mv " + path + " " + copypath)
- found = True
+ updateCache(path, fstamp)
+ copyfile(path)
else:
if cache[path]['ts'] != fstamp[stat.ST_MTIME] or cache[path]['size'] != fstamp[stat.ST_SIZE]:
print "file %s changed" % path
- cache[path] = {}
- cache[path]['ts'] = fstamp[stat.ST_MTIME]
- cache[path]['size'] = fstamp[stat.ST_SIZE]
- if options.copydir:
- copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
- mkdirhier(os.path.split(copypath)[0])
- os.system("mv " + path + " " + copypath)
- found = True
+ updateCache(path, fstamp)
+ copyfile(path)
+ for d in dirs:
+ path = os.path.join(root, d)
+ fstamp = os.lstat(path)
+ if path not in cache:
+ print "new dir %s" % path
+ updateCache(path, fstamp)
+ copydir(path, fstamp)
+ else:
+ if cache[path]['ts'] != fstamp[stat.ST_MTIME]:
+ print "dir %s changed" % path
+ updateCache(path, fstamp)
+ copydir(path, fstamp)
if options.update:
print "Updating"
diff --git a/packages/stage-manager/stagemanager-native_0.0.1.bb b/packages/stage-manager/stagemanager-native_0.0.1.bb
index 7074d37307..828af1fbb5 100644
--- a/packages/stage-manager/stagemanager-native_0.0.1.bb
+++ b/packages/stage-manager/stagemanager-native_0.0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Helper script for packaged-staging.bbclass"
-PR = "r1"
+PR = "r7"
SRC_URI = "file://stage-manager"
LICENSE = "GPLv2"
diff --git a/packages/x11vnc/x11vnc_0.9.3.bb b/packages/x11vnc/x11vnc_0.9.3.bb
index edd165374f..04ac87b444 100644
--- a/packages/x11vnc/x11vnc_0.9.3.bb
+++ b/packages/x11vnc/x11vnc_0.9.3.bb
@@ -3,7 +3,7 @@ SECTION = "x11/utils"
HOMEPAGE = "http://www.karlrunge.com/x11vnc/"
AUTHOR = "Karl Runge"
LICENSE = "GPL"
-DEPENDS = "openssl virtual/libx11 libxext avahi jpeg-62 zlib"
+DEPENDS = "openssl virtual/libx11 libxext avahi jpeg zlib"
SRC_URI = "http://www.karlrunge.com/x11vnc/x11vnc-0.9.3.tar.gz"