summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-06 19:59:44 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-06 19:59:44 +0100
commit9d5481d12accd202313c4585ccd1b440e7a03ebb (patch)
tree2befee9b5aafcbee05d75fcae7d7ae4d24554b00 /packages
parentac56b9f2b15e1ec00f0f04860ed4b5d0da947273 (diff)
parent35805dbc9be008b6849a26061a7c1a3aa227886f (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages')
-rw-r--r--packages/alsa/alsa-state.bb9
-rw-r--r--packages/alsa/alsa-state/a780/asound.state80
-rw-r--r--packages/alsa/alsa-state/a780/gsmhandset.state55
-rw-r--r--packages/alsa/alsa-state/a780/gsmheadset.state55
-rw-r--r--packages/alsa/alsa-state/a780/stereoout.state55
-rw-r--r--packages/ezx/ezx-boot-usb-native.inc32
-rw-r--r--packages/ezx/ezx-boot-usb-native_0.1.0.bb7
-rw-r--r--packages/ezx/ezx-boot-usb-native_0.2.0.bb5
-rw-r--r--packages/ezx/ezx-boot-usb-native_svn.bb29
-rw-r--r--packages/ezx/files/asm-arm/setup.h226
-rw-r--r--packages/images/opie-xqtlauncher-image.bb7
-rw-r--r--packages/toscoterm/toscoterm_git.bb12
-rw-r--r--packages/xqtlauncher/xqtlauncher.bb16
-rw-r--r--packages/xqtlauncher/xqtlauncher/cleanup.desktop5
-rw-r--r--packages/xqtlauncher/xqtlauncher/convert.desktop5
-rwxr-xr-xpackages/xqtlauncher/xqtlauncher/xqtlauncher-cleanup.sh21
-rwxr-xr-xpackages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh23
17 files changed, 279 insertions, 363 deletions
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
index 58c724f79c..ba030e4aab 100644
--- a/packages/alsa/alsa-state.bb
+++ b/packages/alsa/alsa-state.bb
@@ -4,15 +4,16 @@
#
# Filename: alsa-state.bb
-DESCRIPTION = "Default ALSA configuration"
-LICENSE = "GPL"
-PV = "0.1.0"
-PR = "r18"
+DESCRIPTION = "Alsa Scenario Files"
+LICENSE = "MIT"
+PV = "0.2.0"
+PR = "r0"
SRC_URI = "\
file://asound.conf \
file://asound.state \
file://alsa-state \
+ file://*.state \
"
inherit update-rc.d
diff --git a/packages/alsa/alsa-state/a780/asound.state b/packages/alsa/alsa-state/a780/asound.state
deleted file mode 100644
index eafd409857..0000000000
--- a/packages/alsa/alsa-state/a780/asound.state
+++ /dev/null
@@ -1,80 +0,0 @@
-state.EZX {
- control.1 {
- comment.access 'read write'
- comment.type INTEGER
- comment.count 1
- comment.range '0 - 15'
- iface MIXER
- name 'Output gain'
- value 9
- }
- control.2 {
- comment.access 'read write'
- comment.type INTEGER
- comment.count 1
- comment.range '0 - 31'
- iface MIXER
- name 'Input gain'
- value 14
- }
- control.3 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Input Mixer A3 Switch'
- value true
- }
- control.4 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Input Mixer A5 Switch'
- value true
- }
- control.5 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer A1 Switch'
- value true
- }
- control.6 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer A2 Switch'
- value true
- }
- control.7 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer AR Switch'
- value true
- }
- control.8 {
- comment.access 'read write'
- comment.type BOOLEAN
- comment.count 1
- iface MIXER
- name 'Output Mixer AL Switch'
- value true
- }
- control.9 {
- comment.access 'read write'
- comment.type ENUMERATED
- comment.count 1
- comment.item.0 '2ch'
- comment.item.1 '2->1ch'
- comment.item.2 '2->1ch -3db'
- comment.item.3 '2->1ch -6db'
- iface MIXER
- name Downmixer
- value '2ch'
- }
-}
diff --git a/packages/alsa/alsa-state/a780/gsmhandset.state b/packages/alsa/alsa-state/a780/gsmhandset.state
new file mode 100644
index 0000000000..c9adfb3340
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/gsmhandset.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value BP
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Earpiece
+ }
+}
diff --git a/packages/alsa/alsa-state/a780/gsmheadset.state b/packages/alsa/alsa-state/a780/gsmheadset.state
new file mode 100644
index 0000000000..7b72789410
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/gsmheadset.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value BP
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Headset
+ }
+}
diff --git a/packages/alsa/alsa-state/a780/stereoout.state b/packages/alsa/alsa-state/a780/stereoout.state
new file mode 100644
index 0000000000..64b36a0572
--- /dev/null
+++ b/packages/alsa/alsa-state/a780/stereoout.state
@@ -0,0 +1,55 @@
+state.EZX {
+ control.1 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Master Playback Volume'
+ value 6
+ }
+ control.2 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Stereo
+ comment.item.1 Mono
+ comment.item.2 BP
+ iface MIXER
+ name 'DAI Select'
+ value Stereo
+ }
+ control.3 {
+ comment.access 'read write'
+ comment.type INTEGER
+ comment.count 1
+ comment.range '0 - 31'
+ iface MIXER
+ name 'Capture Volume'
+ value 14
+ }
+ control.4 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 '2->1ch'
+ comment.item.2 '2->1ch -3db'
+ comment.item.3 '2->1ch -6db'
+ iface MIXER
+ name Downmixer
+ value Off
+ }
+ control.5 {
+ comment.access 'read write'
+ comment.type ENUMERATED
+ comment.count 1
+ comment.item.0 Off
+ comment.item.1 Loudspeaker
+ comment.item.2 Earpiece
+ comment.item.3 Headset
+ iface MIXER
+ name 'Output mode'
+ value Loudspeaker
+ }
+}
diff --git a/packages/ezx/ezx-boot-usb-native.inc b/packages/ezx/ezx-boot-usb-native.inc
deleted file mode 100644
index e2ebb52df4..0000000000
--- a/packages/ezx/ezx-boot-usb-native.inc
+++ /dev/null
@@ -1,32 +0,0 @@
-DESCRIPTION = "Boots a Motorola EZX device with a user supplied kernel zImage"
-DEPENDS = "libusb-native"
-SECTION = "devel"
-AUTHOR = "Harald Welte <laforge@openezx.org>"
-LICENSE = "GPL"
-
-SRC_URI = "\
- svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http \
- file://asm-arm \
-"
-S = "${WORKDIR}/boot_usb"
-
-inherit native
-
-do_compile() {
- ${CC} -I${WORKDIR} ${CFLAGS} ${LDFLAGS} -lusb -o ezx-boot-usb boot_usb.c
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 ezx-boot-usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
-}
-
-do_stage() {
- :
-}
-
-do_install() {
- :
-}
-
-addtask deploy before do_build after do_compile
diff --git a/packages/ezx/ezx-boot-usb-native_0.1.0.bb b/packages/ezx/ezx-boot-usb-native_0.1.0.bb
deleted file mode 100644
index b70aca3709..0000000000
--- a/packages/ezx/ezx-boot-usb-native_0.1.0.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require ezx-boot-usb-native.inc
-PR = "r0"
-
-SRC_URI = "http://www.openezx.org/download/boot_usb-${PV}.tar.bz2"
-S = "${WORKDIR}/boot_usb-${PV}"
-
-inherit native
diff --git a/packages/ezx/ezx-boot-usb-native_0.2.0.bb b/packages/ezx/ezx-boot-usb-native_0.2.0.bb
deleted file mode 100644
index 7c2883b5b7..0000000000
--- a/packages/ezx/ezx-boot-usb-native_0.2.0.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require ezx-boot-usb-native.inc
-
-SRC_URI = "http://www.openezx.org/download/boot_usb-${PV}.tar.bz2 \
- file://asm-arm"
-S = "${WORKDIR}/boot_usb-${PV}"
diff --git a/packages/ezx/ezx-boot-usb-native_svn.bb b/packages/ezx/ezx-boot-usb-native_svn.bb
index 6ab4263dba..a0a8affdc0 100644
--- a/packages/ezx/ezx-boot-usb-native_svn.bb
+++ b/packages/ezx/ezx-boot-usb-native_svn.bb
@@ -1,5 +1,28 @@
-require ezx-boot-usb-native.inc
+DESCRIPTION = "Boots a Motorola EZX device with a user supplied kernel zImage"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.2.0+svnr${SRCREV}"
-DEFAULT_PREFERENCE = "-1"
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
-PV = "0.2.0+r${SRCREV}"
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile
diff --git a/packages/ezx/files/asm-arm/setup.h b/packages/ezx/files/asm-arm/setup.h
deleted file mode 100644
index 7bbf105463..0000000000
--- a/packages/ezx/files/asm-arm/setup.h
+++ /dev/null
@@ -1,226 +0,0 @@
-/*
- * linux/include/asm/setup.h
- *
- * Copyright (C) 1997-1999 Russell King
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License version 2 as
- * published by the Free Software Foundation.
- *
- * Structure passed to kernel to tell it about the
- * hardware it's running on. See Documentation/arm/Setup
- * for more info.
- */
-#ifndef __ASMARM_SETUP_H
-#define __ASMARM_SETUP_H
-
-#include <asm/types.h>
-
-#define COMMAND_LINE_SIZE 1024
-
-/* The list ends with an ATAG_NONE node. */
-#define ATAG_NONE 0x00000000
-
-struct tag_header {
- __u32 size;
- __u32 tag;
-};
-
-/* The list must start with an ATAG_CORE node */
-#define ATAG_CORE 0x54410001
-
-struct tag_core {
- __u32 flags; /* bit 0 = read-only */
- __u32 pagesize;
- __u32 rootdev;
-};
-
-/* it is allowed to have multiple ATAG_MEM nodes */
-#define ATAG_MEM 0x54410002
-
-struct tag_mem32 {
- __u32 size;
- __u32 start; /* physical start address */
-};
-
-/* VGA text type displays */
-#define ATAG_VIDEOTEXT 0x54410003
-
-struct tag_videotext {
- __u8 x;
- __u8 y;
- __u16 video_page;
- __u8 video_mode;
- __u8 video_cols;
- __u16 video_ega_bx;
- __u8 video_lines;
- __u8 video_isvga;
- __u16 video_points;
-};
-
-/* describes how the ramdisk will be used in kernel */
-#define ATAG_RAMDISK 0x54410004
-
-struct tag_ramdisk {
- __u32 flags; /* bit 0 = load, bit 1 = prompt */
- __u32 size; /* decompressed ramdisk size in _kilo_ bytes */
- __u32 start; /* starting block of floppy-based RAM disk image */
-};
-
-/* describes where the compressed ramdisk image lives (virtual address) */
-/*
- * this one accidentally used virtual addresses - as such,
- * it's deprecated.
- */
-#define ATAG_INITRD 0x54410005
-
-/* describes where the compressed ramdisk image lives (physical address) */
-#define ATAG_INITRD2 0x54420005
-
-struct tag_initrd {
- __u32 start; /* physical start address */
- __u32 size; /* size of compressed ramdisk image in bytes */
-};
-
-/* board serial number. "64 bits should be enough for everybody" */
-#define ATAG_SERIAL 0x54410006
-
-struct tag_serialnr {
- __u32 low;
- __u32 high;
-};
-
-/* board revision */
-#define ATAG_REVISION 0x54410007
-
-struct tag_revision {
- __u32 rev;
-};
-
-/* initial values for vesafb-type framebuffers. see struct screen_info
- * in include/linux/tty.h
- */
-#define ATAG_VIDEOLFB 0x54410008
-
-struct tag_videolfb {
- __u16 lfb_width;
- __u16 lfb_height;
- __u16 lfb_depth;
- __u16 lfb_linelength;
- __u32 lfb_base;
- __u32 lfb_size;
- __u8 red_size;
- __u8 red_pos;
- __u8 green_size;
- __u8 green_pos;
- __u8 blue_size;
- __u8 blue_pos;
- __u8 rsvd_size;
- __u8 rsvd_pos;
-};
-
-/* command line: \0 terminated string */
-#define ATAG_CMDLINE 0x54410009
-
-struct tag_cmdline {
- char cmdline[1]; /* this is the minimum size */
-};
-
-/* acorn RiscPC specific information */
-#define ATAG_ACORN 0x41000101
-
-struct tag_acorn {
- __u32 memc_control_reg;
- __u32 vram_pages;
- __u8 sounddefault;
- __u8 adfsdrives;
-};
-
-/* footbridge memory clock, see arch/arm/mach-footbridge/arch.c */
-#define ATAG_MEMCLK 0x41000402
-
-struct tag_memclk {
- __u32 fmemclk;
-};
-
-struct tag {
- struct tag_header hdr;
- union {
- struct tag_core core;
- struct tag_mem32 mem;
- struct tag_videotext videotext;
- struct tag_ramdisk ramdisk;
- struct tag_initrd initrd;
- struct tag_serialnr serialnr;
- struct tag_revision revision;
- struct tag_videolfb videolfb;
- struct tag_cmdline cmdline;
-
- /*
- * Acorn specific
- */
- struct tag_acorn acorn;
-
- /*
- * DC21285 specific
- */
- struct tag_memclk memclk;
- } u;
-};
-
-struct tagtable {
- __u32 tag;
- int (*parse)(const struct tag *);
-};
-
-#define tag_member_present(tag,member) \
- ((unsigned long)(&((struct tag *)0L)->member + 1) \
- <= (tag)->hdr.size * 4)
-
-#define tag_next(t) ((struct tag *)((__u32 *)(t) + (t)->hdr.size))
-#define tag_size(type) ((sizeof(struct tag_header) + sizeof(struct type)) >> 2)
-
-#define for_each_tag(t,base) \
- for (t = base; t->hdr.size; t = tag_next(t))
-
-#ifdef __KERNEL__
-
-#define __tag __used __attribute__((__section__(".taglist.init")))
-#define __tagtable(tag, fn) \
-static struct tagtable __tagtable_##fn __tag = { tag, fn }
-
-/*
- * Memory map description
- */
-#ifdef CONFIG_ARCH_LH7A40X
-# define NR_BANKS 16
-#else
-# define NR_BANKS 8
-#endif
-
-struct membank {
- unsigned long start;
- unsigned long size;
- int node;
-};
-
-struct meminfo {
- int nr_banks;
- struct membank bank[NR_BANKS];
-};
-
-/*
- * Early command line parameters.
- */
-struct early_params {
- const char *arg;
- void (*fn)(char **p);
-};
-
-#define __early_param(name,fn) \
-static struct early_params __early_##fn __used \
-__attribute__((__section__(".early_param.init"))) = { name, fn }
-
-#endif /* __KERNEL__ */
-
-#endif
diff --git a/packages/images/opie-xqtlauncher-image.bb b/packages/images/opie-xqtlauncher-image.bb
new file mode 100644
index 0000000000..db32a1e893
--- /dev/null
+++ b/packages/images/opie-xqtlauncher-image.bb
@@ -0,0 +1,7 @@
+require opie-image.bb
+
+DEPENDS += "task-xqtlauncher"
+
+export IMAGE_BASENAME = "opie-xqtlauncher-image"
+
+IMAGE_INSTALL += "task-xqtlauncher task-xqtlauncher-blackbox"
diff --git a/packages/toscoterm/toscoterm_git.bb b/packages/toscoterm/toscoterm_git.bb
index a8e5fb8c2f..fd9181d0a0 100644
--- a/packages/toscoterm/toscoterm_git.bb
+++ b/packages/toscoterm/toscoterm_git.bb
@@ -3,11 +3,15 @@ SECTION = "x11/applications"
LICENSE = "GPLv3"
DEPENDS = "vte"
HOMEPAGE = "https://projetos.ossystems.com.br/projects/show/toscoterm"
-PV = "0.0+git${SRCDATE}"
-PR = "r1"
+PV = "0.0+gitr${SRCREV}"
+PR = "r2"
SRC_URI = "git://projetos.ossystems.com.br/git/toscoterm.git;protocol=git"
-
S = "${WORKDIR}/git"
-inherit autotools
+do_compile() {
+ oe_runmake \
+ CC="${CC}" \
+ CFLAGS="${CFLAGS} `pkg-config --cflags gtk-2.0` `pkg-config --cflags vte`" \
+ LDFLAGS="${LDFLAGS} `pkg-config --libs gtk+-2.0` `pkg-config --libs vte`"
+}
diff --git a/packages/xqtlauncher/xqtlauncher.bb b/packages/xqtlauncher/xqtlauncher.bb
index 0897ddb862..043ee566e3 100644
--- a/packages/xqtlauncher/xqtlauncher.bb
+++ b/packages/xqtlauncher/xqtlauncher.bb
@@ -1,13 +1,17 @@
DESCRIPTION = "xqtlauncher integrates X/Qt2 nicely into opie. You can launch applications with it from opies menue"
HOMEPAGE = "http://angstrom-distribution.org/"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
RDEPENDS = "xqt2 xorg-minimal-fonts"
SRC_URI = "file://dot.directory \
file://startxqt \
file://startxqt-wrapper \
+ file://xqtlauncher-convert.sh \
+ file://xqtlauncher-cleanup.sh \
+ file://convert.desktop \
+ file://cleanup.desktop \
file://xqtlauncher "
do_install() {
@@ -15,8 +19,16 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 startxqt startxqt-wrapper xqtlauncher ${D}${bindir}
install -d ${D}${palmtopdir}/apps/XQt2/
- install -m 0644 dot.directory ${D}${palmtopdir}/apps/XQt2
+ install -m 0644 dot.directory ${D}${palmtopdir}/apps/XQt2/.directory
+ install -m 0644 convert.desktop cleanup.desktop ${D}${palmtopdir}/apps/XQt2/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 startxqt startxqt-wrapper xqtlauncher xqtlauncher-cleanup.sh xqtlauncher-convert.sh ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/rc5.d/
+ ln -sf ../init.d/xqtlauncher-convert.sh ${D}${sysconfdir}/rc5.d/S98xqtlauncher-convert
+ ln -sf ../init.d/xqtlauncher-cleanup.sh ${D}${sysconfdir}/rc5.d/S98xqtlauncher-cleanup
}
FILES_${PN} += "${palmtopdir}/apps/XQt2 \
+ ${palmtopdir}/apps/XQt2/convert.desktop \
+ ${palmtopdir}/apps/XQt2/cleanup.desktop \
${palmtopdir}/apps/XQt2/.directory "
diff --git a/packages/xqtlauncher/xqtlauncher/cleanup.desktop b/packages/xqtlauncher/xqtlauncher/cleanup.desktop
new file mode 100644
index 0000000000..d0436178ad
--- /dev/null
+++ b/packages/xqtlauncher/xqtlauncher/cleanup.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Exec=/etc/init.d/xqtlauncher-cleanup.sh
+Icon=Xqt.png
+Type=Application
+Name=Cleanup Icons
diff --git a/packages/xqtlauncher/xqtlauncher/convert.desktop b/packages/xqtlauncher/xqtlauncher/convert.desktop
new file mode 100644
index 0000000000..ca70c43bdb
--- /dev/null
+++ b/packages/xqtlauncher/xqtlauncher/convert.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Exec=/etc/init.d/xqtlauncher-convert.sh
+Icon=Xqt.png
+Type=Application
+Name=Create Icons
diff --git a/packages/xqtlauncher/xqtlauncher/xqtlauncher-cleanup.sh b/packages/xqtlauncher/xqtlauncher/xqtlauncher-cleanup.sh
new file mode 100755
index 0000000000..3ccf333237
--- /dev/null
+++ b/packages/xqtlauncher/xqtlauncher/xqtlauncher-cleanup.sh
@@ -0,0 +1,21 @@
+#!/bin/ash
+#This program cleans up the mess which convert.sh leaves if you remove a package
+for i in `find /usr/lib/opie/apps/XQt2 -name *.desktop`; do
+ export name=$(echo $i | awk 'BEGIN {FS="."} {gsub("/",".")} {print $(NF-1)}')
+ #don't delete convert and cleanup icons
+ if [ $i != "/usr/lib/opie/apps/XQt2/convert.desktop" ] && [ $i != "/usr/lib/opie/apps/XQt2/cleanup.desktop" ] ; then
+ newfile=$(find /usr/share/applications/ -name $name.desktop)
+ else
+ newfile="donotdelete"
+ fi
+ if [ -z $newfile ] ; then
+ echo $name
+ echo $i
+ icon=$(cat $i | awk 'BEGIN {FS="="} {if ($1 == "Icon") {print $2} }')
+ rm -f /usr/lib/opie/bin/run$name
+ find /usr/lib/opie/pics/ -name $icon.* -exec rm -f {} \;
+ rm -f $i
+ fi
+done
+#update the icons
+/usr/bin/icon-reload.sh
diff --git a/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh b/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh
new file mode 100755
index 0000000000..0356d332ff
--- /dev/null
+++ b/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh
@@ -0,0 +1,23 @@
+#!/bin/ash
+#This program converts /usr/share/applications/*.desktop in /usr/lib/opie/apps/XQt2/*.desktop files.
+for i in `find /usr/share/applications -name *.desktop`; do
+ export name=$(echo $i | awk 'BEGIN {FS="."} {gsub("/",".")} {print $(NF-1)}')
+ newfile=/usr/lib/opie/apps/XQt2/$name.desktop
+ if [ ! -f $newfile ] ; then
+ #cat $i | awk 'BEGIN {FS="="} {if ($1 == "Exec") {print "Exec=run"ENVIRON["name"]" " $2} else if ($1 == "Icon") {print "Icon=/usr/share/pixmaps/"$2} else {print $0} }' > $newfile
+ cat $i | awk 'BEGIN {FS="="} {if ($1 == "Exec") {print "Exec=run"ENVIRON["name"]" " $2} else {print $0} }' > $newfile
+ icon=$(cat $i | awk 'BEGIN {FS="="} {if ($1 == "Icon") {print $2} }')
+ ln -sf /usr/bin/xqtlauncher /usr/lib/opie/bin/run$name
+ #We need to make symlinks for the pics because opie can not handle pics with paths :(
+ #Check if it has a leading /!
+ if expr $icon : />/dev/null ; then
+ echo $icon
+ ln -sf $icon /usr/lib/opie/pics/$(echo $icon | awk 'BEGIN {FS="/"} {print $NF}')
+ else
+ echo $icon
+ ln -sf $(find /usr/share/pixmaps -name $icon) /usr/lib/opie/pics/$(echo $icon | awk 'BEGIN {FS="/"} {print $NF}')
+ fi
+ fi
+done
+#update the icons
+/usr/bin/icon-reload.sh