summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-03 11:31:44 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-03 11:31:44 +0100
commit9738e8c6f278acb82e37e9041b2d6c24699edbbd (patch)
treec6ee250e210dd3fd530e4cfac8db2304f185c090 /packages
parent6ae896d88c19cdd6f7c16dcd2f3d59b407909980 (diff)
policykit: create polkituser
Diffstat (limited to 'packages')
-rw-r--r--packages/policykit/policykit_0.9.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/policykit/policykit_0.9.bb b/packages/policykit/policykit_0.9.bb
index 38d86afe64..3fb5dc72d8 100644
--- a/packages/policykit/policykit_0.9.bb
+++ b/packages/policykit/policykit_0.9.bb
@@ -1,6 +1,8 @@
HOMEPAGE = "http://www.packagekit.org/"
DEPENDS = "libpam expat dbus-glib"
+PR = "r1"
+
SRC_URI = "http://hal.freedesktop.org/releases/PolicyKit-${PV}.tar.gz"
EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc"
@@ -17,3 +19,19 @@ FILES_${PN} += " ${datadir}/dbus-1 \
${datadir}/PolicyKit \
"
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^polkituser:" /etc/group > /dev/null || addgroup polkituser grep "^polkituser:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/run/polkit polkituser --ingroup polkituser -g Avahi
+ DBUSPID=`pidof dbus-daemon`
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_${PN} () {
+ deluser polkituser || true
+ delgroup polkituser || true
+}