summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-05 16:15:55 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-05 16:15:55 +0100
commit95179323c0d9792c4578e6a05297d3feb58a2f28 (patch)
tree5b5f49dd6030b7dbb8f47f57478f38f2266f5697 /packages
parentab2e2fa85cf5622d5307586221a7bb1e21e68dc4 (diff)
readline: update to 5.2
* strangely enough already in checksums.ini
Diffstat (limited to 'packages')
-rw-r--r--packages/readline/readline_5.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/readline/readline_5.2.bb b/packages/readline/readline_5.2.bb
new file mode 100644
index 0000000000..acbefa8939
--- /dev/null
+++ b/packages/readline/readline_5.2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
+command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
+additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
+lines, and perform csh-like history expansion on previous commands."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS += "ncurses"
+RPROVIDES_${PN} += "readline"
+LEAD_SONAME = "libreadline.so"
+
+SRC_URI = "${GNU_MIRROR}/readline/readline-${PV}.tar.gz \
+ file://acinclude.m4"
+S = "${WORKDIR}/readline-${PV}"
+
+inherit autotools
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install () {
+ autotools_do_install
+ # Make install doesn't properly install these
+ oe_libinstall -so -C shlib libhistory ${D}${libdir}
+ oe_libinstall -so -C shlib libreadline ${D}${libdir}
+}