summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2006-05-25 17:58:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-25 17:58:55 +0000
commit86c7a226dcf5dbd77f68509c625f8cd78a89e17c (patch)
tree574d2e9c4653a170c2a36e98867a1e57a25bc6e3 /packages
parentafb6c683b661ab772a70226f76fcf90f137d4a9e (diff)
parentde1d2a3d79046f46866116bbb47b5f5b1391938d (diff)
merge of 311aee6b0e9c7e9db57f288fca6db1879c2922e8
and a7eb3356e7d55322be61cd06888673575122e3b9
Diffstat (limited to 'packages')
-rw-r--r--packages/altboot/altboot_1.0.7-rc3.bb93
-rw-r--r--packages/altboot/files/init.altboot10
-rw-r--r--packages/glibc/glibc_2.3.5+cvs20050627.bb5
-rw-r--r--packages/kbdd/files/kbdd.init5
4 files changed, 106 insertions, 7 deletions
diff --git a/packages/altboot/altboot_1.0.7-rc3.bb b/packages/altboot/altboot_1.0.7-rc3.bb
new file mode 100644
index 0000000000..245cf2a426
--- /dev/null
+++ b/packages/altboot/altboot_1.0.7-rc3.bb
@@ -0,0 +1,93 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: altboot_1.0.5-rc2.bb
+# Date: 21-Feb-06
+
+DESCRIPTION = "The altboot bootmanager"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
+LICENSE = "GPL"
+
+######################################################################################
+
+RRECOMMENDS_${PN} = "e2fsprogs-e2fsck dosfstools"
+RRECOMMENDS_${PN}_append_akita = " kexec-tools"
+RRECOMMENDS_${PN}_append_spitz = " kexec-tools"
+RRECOMMENDS_${PN}_append_c7x0 = " kexec-tools"
+
+RDEPENDS_${PN} = "${PN}-conf"
+RDEPENDS_${PN}-conf = "${PN}"
+
+######################################################################################
+
+PR = "r0"
+
+######################################################################################
+
+PACKAGES = "${PN}-conf ${PN}-doc ${PN}"
+
+PACKAGE_ARCH_${PN} = all
+PACKAGE_ARCH_${PN}-doc = all
+PACKAGE_ARCH_${PN}-conf = "${MACHINE}"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+SRC_URI = "cvs://anonymous@hentges.net/hentgescvs;method=pserver;tag=${TAG};module=altboot"
+
+S = "${WORKDIR}/altboot/"
+
+######################################################################################
+
+FILES_${PN}-conf = "/etc/altboot*.cfg"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}/sbin
+ install -d ${D}/etc/altboot-menu
+ install -d ${D}/etc/altboot-menu/Advanced
+ install -d ${D}/etc/altboot.rc
+ install -d ${D}/usr/share/doc/altboot
+ install -d ${D}/usr/share/sounds
+
+ if test -d ${WORKDIR}/altboot/${MACHINE}
+ then
+ install -m 0644 ${WORKDIR}/altboot/${MACHINE}/altboot*.cfg ${D}/etc
+ else
+ install -m 0644 ${WORKDIR}/altboot/altboot*.cfg ${D}/etc
+ fi
+
+ install -m 0644 ${WORKDIR}/altboot/beep.raw ${D}/usr/share/sounds
+ install -m 0644 ${WORKDIR}/altboot/altboot.func ${D}/etc
+ install -m 0755 ${WORKDIR}/altboot/init.altboot ${D}/sbin
+
+ install -m 0755 ${WORKDIR}/altboot/altboot-menu/*-* ${D}/etc/altboot-menu
+
+ install -m 0755 ${WORKDIR}/altboot/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+
+ install -m 0755 ${WORKDIR}/altboot/altboot.rc/*.sh ${D}/etc/altboot.rc
+ install -m 0644 ${WORKDIR}/altboot/altboot.rc/*.txt ${D}/etc/altboot.rc
+}
+
+######################################################################################
+
+do_configure() {
+ cat ${WORKDIR}/altboot/init.altboot | sed "s/^VERSION=.*/VERSION=\"${PV}\"/" > ${WORKDIR}/altboot/init.altboot_
+ mv ${WORKDIR}/altboot/init.altboot_ ${WORKDIR}/altboot/init.altboot
+}
+
+######################################################################################
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /sbin/init init /sbin/init.altboot 55
+}
+
+######################################################################################
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove init /sbin/init.altboot
+}
+
diff --git a/packages/altboot/files/init.altboot b/packages/altboot/files/init.altboot
index 2c106efa73..08ba81e962 100644
--- a/packages/altboot/files/init.altboot
+++ b/packages/altboot/files/init.altboot
@@ -177,12 +177,9 @@ run_timer() {
case "`uname -r`" in
2.4*) key_ints="`cat /proc/interrupts | grep keyboard | awk '{print $2}'`";;
2.6*) key_ints="`cat /proc/interrupts | grep Spitzkbd`"
- test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i corgikbd`"
- test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i locomokbd`";;
+ test -z "$key_ints" && key_ints="`cat /proc/interrupts | grep -i corgikbd`";;
esac
- test -z "$key_ints" && debug_echo "Couldn't read keyboard ints!"
-
stty -echo <"$OUT_TTY" >"$OUT_TTY" 2>&1
echo -en "\n\nPlease press any key to launch altboot." > "$OUT_TTY"
@@ -195,8 +192,7 @@ run_timer() {
case "`uname -r`" in
2.4*) key_ints_now="`cat /proc/interrupts | grep keyboard | awk '{print $2}'`";;
2.6*) key_ints_now="`cat /proc/interrupts | grep Spitzkbd`"
- test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i corgikbd`"
- test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i locomokbd`";;
+ test -z "$key_ints_now" && key_ints_now="`cat /proc/interrupts | grep -i corgikbd`";;
esac
if test "$key_ints_now" != "$key_ints" -o -z "$key_ints_now"
@@ -327,7 +323,7 @@ then
debug_shell 4 >/dev/null 2>&1 &
fi
-if test -f /proc/cmdline -a "`ps ax|wc -l|tr -d " "`" -gt 30 -a "$1" != "-force" -a "$1" != "+force"
+if test -f /proc/cmdline -a "`ps ax|wc -l|tr -d " "`" -gt 30 -a "$1" != "-force"
then
echo "altboot: Using real init [$REAL_INIT] [$*] [`ps ax|wc -l|tr -d " "`] *" >"$OUT_TTY"
exec $REAL_INIT $*
diff --git a/packages/glibc/glibc_2.3.5+cvs20050627.bb b/packages/glibc/glibc_2.3.5+cvs20050627.bb
index 86ddc91fd0..024ba1d901 100644
--- a/packages/glibc/glibc_2.3.5+cvs20050627.bb
+++ b/packages/glibc/glibc_2.3.5+cvs20050627.bb
@@ -106,7 +106,12 @@ do_munge() {
addtask munge before do_patch after do_unpack
+export default_mmap_threshold_familiar = "32*1024"
+
do_configure () {
+ if [ "x$default_mmap_threshold" != "x" ]; then
+ echo "malloc-CPPFLAGS=-DDEFAULT_MMAP_THRESHOLD=\"(${default_mmap_threshold})\"" >configparms
+ fi
# override this function to avoid the autoconf/automake/aclocal/autoheader
# calls for now
# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
diff --git a/packages/kbdd/files/kbdd.init b/packages/kbdd/files/kbdd.init
index c9e0a0deac..00aec07aa7 100644
--- a/packages/kbdd/files/kbdd.init
+++ b/packages/kbdd/files/kbdd.init
@@ -12,6 +12,11 @@ case $1 in
killall kbdd
;;
+'restart')
+ $0 stop
+ $o start
+ ;;
+
*)
echo "usage: $0 { start | stop | restart }"
;;