summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-03-19 15:08:05 +0000
committerKoen Kooi <koen@openembedded.org>2007-03-19 15:08:05 +0000
commit77e2700bbc7aaee3d9fb8dbccc90a2ba0048bc38 (patch)
tree227bda18d9f283bc0f53dabd50bb108c3eea38fe /packages
parent6aafdd3cdfe06a45dd4cf6725eed7b2d6f594011 (diff)
parentbaa75269ade62d98a062a036f6d0533e7f617e32 (diff)
merge of 'd03e6ea9b33f8649e0fd60a9e531f435ef2a40ca'
and 'e2140c3f36090f469a27ce291b4786eb114eafce'
Diffstat (limited to 'packages')
-rw-r--r--packages/gcc/gcc-cross_4.1.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.1.2.bb b/packages/gcc/gcc-cross_4.1.2.bb
new file mode 100644
index 0000000000..bb1114cf3b
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.1.2.bb
@@ -0,0 +1,18 @@
+require gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r0"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"