summaryrefslogtreecommitdiff
path: root/packages
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-18 01:39:07 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-18 01:39:07 +0000
commit464d501ed34c9b151ff535d95efc4f4b29d4b761 (patch)
tree999d33a1d62fd562c240788528519d91fd35c155 /packages
parentf423928298938b2b053cc80b68fd93d21fe614bf (diff)
slugos: Added support for DISTR_EXTRA_{DEPENDS,RDEPENDS,RRECOMMENDS}
Diffstat (limited to 'packages')
-rw-r--r--packages/images/slugos-image.bb10
-rw-r--r--packages/tasks/task-slugos.bb88
2 files changed, 77 insertions, 21 deletions
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index 3a275b189e..d78528d700 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -8,6 +8,9 @@ HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
PR = "r46"
+DEPENDS = "task-slugos"
+PACKAGE_INSTALL = "task-slugos"
+
COMPATIBLE_MACHINE = "nslu2"
IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
@@ -31,11 +34,4 @@ SLUGOS_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device
IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
IMAGE_PREPROCESS_COMMAND += "install -c -m 644 ${SLUGOS_DEVICE_TABLE} ${IMAGE_ROOTFS}/etc/device_table;"
-SLUGOS_EXTRA_INSTALL ?= ""
-
-DEPENDS = "task-slugos"
-RDEPENDS = "task-slugos ${SLUGOS_EXTRA_INSTALL}"
-
-PACKAGE_INSTALL = "${RDEPENDS}"
-
inherit image nslu2-image dsmg600-image nas100d-image
diff --git a/packages/tasks/task-slugos.bb b/packages/tasks/task-slugos.bb
index c25dcd973f..04ac07de0d 100644
--- a/packages/tasks/task-slugos.bb
+++ b/packages/tasks/task-slugos.bb
@@ -10,13 +10,14 @@ PR = "r2"
PACKAGE_ARCH = "${MACHINE_ARCH}"
ALLOW_EMPTY = "1"
-# CONFIG:
-# SLUGOS_EXTRA_RDEPENDS: set in conf, things to add to the image
-# SLUGOS_SUPPORT: set here, see below, added to the image.
-# SLUGOS_KERNEL: set here, kernel modules added to the image
-#
-# Do not override the last two unless you really know what you
-# are doing - there is more information below.
+#----------------------------------------------------------------------------------
+# FIRMWARE CONFIGURATION
+#----------------------------------------------------------------------------------
+# EXTRA PACKAGES
+# --------------
+# The standard firmware contents and additional packages built as requirements
+# of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.
+SLUGOS_STANDARD_RDEPENDS = ""
# diff, cpio and find are required for reflash and turnup ram.
# Removing these probably leaves the system bootable, but standard
@@ -26,13 +27,71 @@ ALLOW_EMPTY = "1"
# udev is the default way of handling devices, there is no guarantee
# that the static device table is completely correct (it is just
# known to be sufficient for boot.)
-SLUGOS_SUPPORT ?= "diffutils cpio findutils udev"
+SLUGOS_STANDARD_RDEPENDS += "diffutils cpio findutils udev"
+
+# These lines add support for formatting ext2 and ext3 file systems
+# on a hard disk attached to the NSLU2. ext3 is the standard Linux
+# file system.
+SLUGOS_STANDARD_RDEPENDS += "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
+
+# These lines add support for an X/Y/ZModem package called lrzsz
+# (this is of use for people with modified NSLU2 hardware which
+# supports a serial port.)
+SLUGOS_STANDARD_RDEPENDS += "lrzsz"
+
+# Filesystem selection. Adding entries here adds the module to the
+# image. The module must be built as part of nslu2-kernel (i.e. it
+# must be specified as a module in the defconfig file). The NLS
+# support charset modules must be given explicitly and must match
+# the codepage/iocharset and NLS handling for the file systems which
+# require them. The installed lanugage set is minimal but sufficient
+# for any file system (since it uses utf8). See
+# http://www.nslu2-linux.orgwiki/HowTo/MountFATFileSystems
+# for more information on the language behaviour of the DOS file
+# systems.
+#
+# KERNEL LEVEL FILE SYSTEM SUPPORT
+# --------------------------------
+# NOTE: removing kernel-module-nfs from this list will prevent NFS
+# boot (however you can do a simple flash file system boot - no
+# attached disk - and install the nfs modules from ssh.)
+SLUGOS_STANDARD_RDEPENDS += "\
+kernel-module-ext2 \
+kernel-module-jbd \
+kernel-module-ext3 \
+kernel-module-vfat \
+kernel-module-ntfs \
+kernel-module-isofs \
+kernel-module-udf \
+kernel-module-nls-cp437 \
+kernel-module-nls-utf8 \
+"
-SLUGOS_KERNEL ?= ""
+# Add daemon required for HW RNG support
+SLUGOS_STANDARD_RDEPENDS += "\
+rng-tools \
+"
-SLUGOS_EXTRA_RDEPENDS ?= ""
+# Add modules required for usb support
+SLUGOS_STANDARD_RDEPENDS += "\
+kernel-module-ohci-hcd \
+kernel-module-uhci-hcd \
+"
-RDEPENDS = "kernel ixp4xx-npe \
+# Add modules required for IDE support
+SLUGOS_STANDARD_RDEPENDS += "\
+kernel-module-libata \
+kernel-module-pata-artop \
+"
+
+# Add modules required for Network support
+SLUGOS_STANDARD_RDEPENDS += "\
+kernel-module-via-velocity \
+"
+
+DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
+
+RDEPENDS += "kernel ixp4xx-npe \
base-files base-passwd netbase \
busybox initscripts-slugos slugos-init \
update-modules sysvinit tinylogin \
@@ -46,6 +105,7 @@ RDEPENDS = "kernel ixp4xx-npe \
util-linux-umount \
util-linux-swaponoff \
util-linux-losetup \
- ${SLUGOS_SUPPORT} \
- ${SLUGOS_KERNEL} \
- ${SLUGOS_EXTRA_RDEPENDS}"
+ ${SLUGOS_STANDARD_RDEPENDS} \
+ ${DISTRO_EXTRA_RDEPENDS}"
+
+RRECOMMENDS = "${DISTRO_EXTRA_RRECOMMENDS}"