summaryrefslogtreecommitdiff
path: root/packages/zten/zten_1.6.2.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-13 09:23:00 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-05-13 09:23:00 +0000
commitc4100bfd5300f697a551e7bb8a33d8159f863fb0 (patch)
tree274d07930b52e1e3ae412df24c941fe4aecb54a9 /packages/zten/zten_1.6.2.bb
parent05f5c4d39c0688d428f44f6caf3cf4d580cbed74 (diff)
zten: add zten for the first time.
zten is a EB*/EPWING dictionary browser, a format popular for ebooks in Japan.
Diffstat (limited to 'packages/zten/zten_1.6.2.bb')
-rw-r--r--packages/zten/zten_1.6.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/zten/zten_1.6.2.bb b/packages/zten/zten_1.6.2.bb
new file mode 100644
index 0000000000..1511341f0a
--- /dev/null
+++ b/packages/zten/zten_1.6.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "EB*/EPWING dictionary browser for Linux Zaurus"
+HOMEPAGE = "http://www.gohome.org/zten"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "eb kakasi"
+RDEPENDS = "virtual/japanese-font"
+RCONFLICTS = "ztenv"
+
+SRC_URI = "http://www.gohome.org/cgi-bin/viewcvs.cgi/zten.tar.gz;md5sum=d24f03c8df5c98d510590bd9a63dc9321 \
+ file://zten.patch;patch=1"
+
+S = "${WORKDIR}/zten"
+
+inherit palmtop
+
+CXXFLAGS += " -DQWS"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/pics
+ install -m 0755 zten ${D}${palmtopdir}/bin/zten
+ install -m 0644 zten.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 Zten.png ${D}${palmtopdir}/pics
+}
+