summaryrefslogtreecommitdiff
path: root/packages/zlib/zlib_1.2.3.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2006-08-07 21:04:36 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2006-08-07 21:04:36 +0000
commit1cb8bf5179e4c38c0eb09dcf7ea0309fbfad195e (patch)
tree6a31e8b2ac236f79e35f4197f23ba629ce6a3ad4 /packages/zlib/zlib_1.2.3.bb
parent288ecbe2bc5aab2daebd615cda1d6a25632b7227 (diff)
zlib-1.2.3: -made zlib uses autotools, that introduced autotools.patch and
make libtool_staging.patch and sane-target.patch obsolete -adding myself as maintainer after talked with kergoth -simplify zlib_1.2.3.bb
Diffstat (limited to 'packages/zlib/zlib_1.2.3.bb')
-rw-r--r--packages/zlib/zlib_1.2.3.bb23
1 files changed, 4 insertions, 19 deletions
diff --git a/packages/zlib/zlib_1.2.3.bb b/packages/zlib/zlib_1.2.3.bb
index 8a48a89fdf..507b32eff9 100644
--- a/packages/zlib/zlib_1.2.3.bb
+++ b/packages/zlib/zlib_1.2.3.bb
@@ -1,39 +1,24 @@
DESCRIPTION = "Zlib Compression Library"
SECTION = "libs"
PRIORITY = "required"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+MAINTAINER = "Henning Heinold <heinold@inf.fu-berlin.de>"
HOMEPAGE = "http://www.gzip.org/zlib/"
LICENSE = "zlib"
+PR="r1"
SRC_URI = "http://www.zlib.net/zlib-1.2.3.tar.bz2 \
file://visibility.patch;patch=1 \
- file://libtool_staging.patch;patch=1 \
- file://sane-target.patch;patch=1 "
+ file://autotools.patch;patch=1 "
S = "${WORKDIR}/zlib-${PV}"
DEPENDS = "libtool-cross"
-export LDSHARED = "${CC} -shared -Wl,-soname,libz.so.1"
-LDFLAGS_append = " -L. -lz"
-CFLAGS_prepend = "-fPIC -DZLIB_DLL "
-AR_append = " rc"
-EXTRA_OEMAKE = " LIBTOOL=${TARGET_SYS}-libtool"
-
-# extra configure options, can be reset in the -native variant
-ZLIB_EXTRA = "--target=${TARGET_OS}"
-ZLIB_SHARED= "libz.so.${PV}"
-
-do_compile() {
- ./configure --prefix=${prefix} --exec_prefix=${exec_prefix} --shared --libdir=${libdir} --includedir=${includedir} ${ZLIB_EXTRA}
- oe_runmake -e MAKEFLAGS="" ${ZLIB_SHARED} libz.a
-}
+inherit autotools
do_stage() {
install -m 0644 zlib.h ${STAGING_INCDIR}/zlib.h
install -m 0644 zconf.h ${STAGING_INCDIR}/zconf.h
-
- mv libz.la ${STAGING_LIBDIR}/
oe_libinstall -a -so libz ${STAGING_LIBDIR}
}