summaryrefslogtreecommitdiff
path: root/packages/zlib/zlib-native_1.2.3.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-08-06 19:45:08 +0000
committerHolger Freyther <zecke@selfish.org>2006-08-06 19:45:08 +0000
commit4f808eb2f1265e33852fb926fe74d04ba9d27b9a (patch)
tree4541e92b2a5b6edc360fc0ab1ac6b9fa6cc93b07 /packages/zlib/zlib-native_1.2.3.bb
parentccec27323e3f552fcd1af2ff90fe099be0c88401 (diff)
packaes/zlib: Do not use uname to determine the library ending
Do not use uname to decide if the library ends with dylib or so. And where to put the Version numbers... For darwin unset LDSHARED as we do not have gcc -shared to zlib should use autofoo to decide such things...
Diffstat (limited to 'packages/zlib/zlib-native_1.2.3.bb')
-rw-r--r--packages/zlib/zlib-native_1.2.3.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/packages/zlib/zlib-native_1.2.3.bb b/packages/zlib/zlib-native_1.2.3.bb
index c568358694..c7defb6aac 100644
--- a/packages/zlib/zlib-native_1.2.3.bb
+++ b/packages/zlib/zlib-native_1.2.3.bb
@@ -1,6 +1,16 @@
SECTION = "libs"
require zlib_${PV}.bb
+ZLIB_EXTRA = ""
inherit native
DEPENDS = "libtool-native"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/zlib-${PV}', '${FILE_DIRNAME}/zlib', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+
+
+# darwin hacks
+ZLIB_SHARED_build-darwin ="libz.1.2.3.dylib"
+do_compile_build-darwin() {
+ unset LDSHARED
+ ./configure --prefix=${prefix} --exec_prefix=${exec_prefix} --shared --libdir=${libdir} --includedir=${includedir}
+ oe_runmake
+}