summaryrefslogtreecommitdiff
path: root/packages/zlib/files/autotools.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/zlib/files/autotools.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/zlib/files/autotools.patch')
-rw-r--r--packages/zlib/files/autotools.patch672
1 files changed, 0 insertions, 672 deletions
diff --git a/packages/zlib/files/autotools.patch b/packages/zlib/files/autotools.patch
deleted file mode 100644
index 166e7669ad..0000000000
--- a/packages/zlib/files/autotools.patch
+++ /dev/null
@@ -1,672 +0,0 @@
-diff -Naur zlib-1.2.3/configure zlib-1.2.3new/configure
---- zlib-1.2.3/configure 2005-07-11 22:11:57.000000000 +0200
-+++ zlib-1.2.3new/configure 1970-01-01 01:00:00.000000000 +0100
-@@ -1,459 +0,0 @@
--#!/bin/sh
--# configure script for zlib. This script is needed only if
--# you wish to build a shared library and your system supports them,
--# of if you need special compiler, flags or install directory.
--# Otherwise, you can just use directly "make test; make install"
--#
--# To create a shared library, use "configure --shared"; by default a static
--# library is created. If the primitive shared library support provided here
--# does not work, use ftp://prep.ai.mit.edu/pub/gnu/libtool-*.tar.gz
--#
--# To impose specific compiler or flags or install directory, use for example:
--# prefix=$HOME CC=cc CFLAGS="-O4" ./configure
--# or for csh/tcsh users:
--# (setenv prefix $HOME; setenv CC cc; setenv CFLAGS "-O4"; ./configure)
--# LDSHARED is the command to be used to create a shared library
--
--# Incorrect settings of CC or CFLAGS may prevent creating a shared library.
--# If you have problems, try without defining CC and CFLAGS before reporting
--# an error.
--
--LIBS=libz.a
--LDFLAGS="-L. ${LIBS}"
--VER=`sed -n -e '/VERSION "/s/.*"\(.*\)".*/\1/p' < zlib.h`
--VER2=`sed -n -e '/VERSION "/s/.*"\([0-9]*\\.[0-9]*\)\\..*/\1/p' < zlib.h`
--VER1=`sed -n -e '/VERSION "/s/.*"\([0-9]*\)\\..*/\1/p' < zlib.h`
--AR=${AR-"ar rc"}
--RANLIB=${RANLIB-"ranlib"}
--prefix=${prefix-/usr/local}
--exec_prefix=${exec_prefix-'${prefix}'}
--libdir=${libdir-'${exec_prefix}/lib'}
--includedir=${includedir-'${prefix}/include'}
--mandir=${mandir-'${prefix}/share/man'}
--shared_ext='.so'
--shared=0
--gcc=0
--old_cc="$CC"
--old_cflags="$CFLAGS"
--
--while test $# -ge 1
--do
--case "$1" in
-- -h* | --h*)
-- echo 'usage:'
-- echo ' configure [--shared] [--prefix=PREFIX] [--exec_prefix=EXPREFIX]'
-- echo ' [--libdir=LIBDIR] [--includedir=INCLUDEDIR]'
-- exit 0;;
-- -p*=* | --p*=*) prefix=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -e*=* | --e*=*) exec_prefix=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -l*=* | --libdir=*) libdir=`echo $1 | sed 's/[-a-z_]*=//'`; shift;;
-- -i*=* | --includedir=*) includedir=`echo $1 | sed 's/[-a-z_]*=//'`;shift;;
-- -p* | --p*) prefix="$2"; shift; shift;;
-- -e* | --e*) exec_prefix="$2"; shift; shift;;
-- -l* | --l*) libdir="$2"; shift; shift;;
-- -i* | --i*) includedir="$2"; shift; shift;;
-- -s* | --s*) shared=1; shift;;
-- *) echo "unknown option: $1"; echo "$0 --help for help"; exit 1;;
-- esac
--done
--
--test=ztest$$
--cat > $test.c <<EOF
--extern int getchar();
--int hello() {return getchar();}
--EOF
--
--test -z "$CC" && echo Checking for gcc...
--cc=${CC-gcc}
--cflags=${CFLAGS-"-O3"}
--# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
--case "$cc" in
-- *gcc*) gcc=1;;
--esac
--
--if test "$gcc" -eq 1 && ($cc -c $cflags $test.c) 2>/dev/null; then
-- CC="$cc"
-- SFLAGS=${CFLAGS-"-fPIC -O3"}
-- CFLAGS="$cflags"
-- case `(uname -s || echo unknown) 2>/dev/null` in
-- Linux | linux | GNU | GNU/*) LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1"};;
-- CYGWIN* | Cygwin* | cygwin* | OS/2* )
-- EXE='.exe';;
-- QNX*) # This is for QNX6. I suppose that the QNX rule below is for QNX2,QNX4
-- # (alain.bonnefoy@icbt.com)
-- LDSHARED=${LDSHARED-"$cc -shared -Wl,-hlibz.so.1"};;
-- HP-UX*)
-- LDSHARED=${LDSHARED-"$cc -shared $SFLAGS"}
-- case `(uname -m || echo unknown) 2>/dev/null` in
-- ia64)
-- shared_ext='.so'
-- SHAREDLIB='libz.so';;
-- *)
-- shared_ext='.sl'
-- SHAREDLIB='libz.sl';;
-- esac;;
-- Darwin*) shared_ext='.dylib'
-- SHAREDLIB=libz$shared_ext
-- SHAREDLIBV=libz.$VER$shared_ext
-- SHAREDLIBM=libz.$VER1$shared_ext
-- LDSHARED=${LDSHARED-"$cc -dynamiclib -install_name $libdir/$SHAREDLIBM -compatibility_version $VER1 -current_version $VER"};;
-- *) LDSHARED=${LDSHARED-"$cc -shared"};;
-- esac
--else
-- # find system name and corresponding cc options
-- CC=${CC-cc}
-- case `(uname -sr || echo unknown) 2>/dev/null` in
-- HP-UX*) SFLAGS=${CFLAGS-"-O +z"}
-- CFLAGS=${CFLAGS-"-O"}
--# LDSHARED=${LDSHARED-"ld -b +vnocompatwarnings"}
-- LDSHARED=${LDSHARED-"ld -b"}
-- case `(uname -m || echo unknown) 2>/dev/null` in
-- ia64)
-- shared_ext='.so'
-- SHAREDLIB='libz.so';;
-- *)
-- shared_ext='.sl'
-- SHAREDLIB='libz.sl';;
-- esac;;
-- IRIX*) SFLAGS=${CFLAGS-"-ansi -O2 -rpath ."}
-- CFLAGS=${CFLAGS-"-ansi -O2"}
-- LDSHARED=${LDSHARED-"cc -shared"};;
-- OSF1\ V4*) SFLAGS=${CFLAGS-"-O -std1"}
-- CFLAGS=${CFLAGS-"-O -std1"}
-- LDSHARED=${LDSHARED-"cc -shared -Wl,-soname,libz.so -Wl,-msym -Wl,-rpath,$(libdir) -Wl,-set_version,${VER}:1.0"};;
-- OSF1*) SFLAGS=${CFLAGS-"-O -std1"}
-- CFLAGS=${CFLAGS-"-O -std1"}
-- LDSHARED=${LDSHARED-"cc -shared"};;
-- QNX*) SFLAGS=${CFLAGS-"-4 -O"}
-- CFLAGS=${CFLAGS-"-4 -O"}
-- LDSHARED=${LDSHARED-"cc"}
-- RANLIB=${RANLIB-"true"}
-- AR="cc -A";;
-- SCO_SV\ 3.2*) SFLAGS=${CFLAGS-"-O3 -dy -KPIC "}
-- CFLAGS=${CFLAGS-"-O3"}
-- LDSHARED=${LDSHARED-"cc -dy -KPIC -G"};;
-- SunOS\ 5*) SFLAGS=${CFLAGS-"-fast -xcg89 -KPIC -R."}
-- CFLAGS=${CFLAGS-"-fast -xcg89"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- SunOS\ 4*) SFLAGS=${CFLAGS-"-O2 -PIC"}
-- CFLAGS=${CFLAGS-"-O2"}
-- LDSHARED=${LDSHARED-"ld"};;
-- SunStudio\ 9*) SFLAGS=${CFLAGS-"-DUSE_MMAP -fast -xcode=pic32 -xtarget=ultra3 -xarch=v9b"}
-- CFLAGS=${CFLAGS-"-DUSE_MMAP -fast -xtarget=ultra3 -xarch=v9b"}
-- LDSHARED=${LDSHARED-"cc -xarch=v9b"};;
-- UNIX_System_V\ 4.2.0)
-- SFLAGS=${CFLAGS-"-KPIC -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- UNIX_SV\ 4.2MP)
-- SFLAGS=${CFLAGS-"-Kconform_pic -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- OpenUNIX\ 5)
-- SFLAGS=${CFLAGS-"-KPIC -O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -G"};;
-- AIX*) # Courtesy of dbakker@arrayasolutions.com
-- SFLAGS=${CFLAGS-"-O -qmaxmem=8192"}
-- CFLAGS=${CFLAGS-"-O -qmaxmem=8192"}
-- LDSHARED=${LDSHARED-"xlc -G"};;
-- # send working options for other systems to support@gzip.org
-- *) SFLAGS=${CFLAGS-"-O"}
-- CFLAGS=${CFLAGS-"-O"}
-- LDSHARED=${LDSHARED-"cc -shared"};;
-- esac
--fi
--
--SHAREDLIB=${SHAREDLIB-"libz$shared_ext"}
--SHAREDLIBV=${SHAREDLIBV-"libz$shared_ext.$VER"}
--SHAREDLIBM=${SHAREDLIBM-"libz$shared_ext.$VER1"}
--
--if test $shared -eq 1; then
-- echo Checking for shared library support...
-- # we must test in two steps (cc then ld), required at least on SunOS 4.x
-- if test "`($CC -c $SFLAGS $test.c) 2>&1`" = "" &&
-- test "`($LDSHARED -o $test$shared_ext $test.o) 2>&1`" = ""; then
-- CFLAGS="$SFLAGS"
-- LIBS="$SHAREDLIBV"
-- echo Building shared library $SHAREDLIBV with $CC.
-- elif test -z "$old_cc" -a -z "$old_cflags"; then
-- echo No shared library support.
-- shared=0;
-- else
-- echo 'No shared library support; try without defining CC and CFLAGS'
-- shared=0;
-- fi
--fi
--if test $shared -eq 0; then
-- LDSHARED="$CC"
-- echo Building static library $LIBS version $VER with $CC.
--else
-- LDFLAGS="-L. ${SHAREDLIBV}"
--fi
--
--cat > $test.c <<EOF
--#include <unistd.h>
--int main() { return 0; }
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- sed < zconf.in.h "/HAVE_UNISTD_H/s%0%1%" > zconf.h
-- echo "Checking for unistd.h... Yes."
--else
-- cp -p zconf.in.h zconf.h
-- echo "Checking for unistd.h... No."
--fi
--
--cat > $test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--#include "zconf.h"
--
--int main()
--{
--#ifndef STDC
-- choke me
--#endif
--
-- return 0;
--}
--EOF
--
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()"
--
-- cat > $test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- vsnprintf(buf, sizeof(buf), fmt, ap);
-- va_end(ap);
-- return 0;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-- echo "Checking for vsnprintf() in stdio.h... Yes."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- int n;
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- n = vsnprintf(buf, sizeof(buf), fmt, ap);
-- va_end(ap);
-- return n;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of vsnprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_vsnprintf_void"
-- echo "Checking for return value of vsnprintf()... No."
-- echo " WARNING: apparently vsnprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- else
-- CFLAGS="$CFLAGS -DNO_vsnprintf"
-- echo "Checking for vsnprintf() in stdio.h... No."
-- echo " WARNING: vsnprintf() not found, falling back to vsprintf(). zlib"
-- echo " can build but will be open to possible buffer-overflow security"
-- echo " vulnerabilities."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--#include <stdarg.h>
--
--int mytest(char *fmt, ...)
--{
-- int n;
-- char buf[20];
-- va_list ap;
--
-- va_start(ap, fmt);
-- n = vsprintf(buf, fmt, ap);
-- va_end(ap);
-- return n;
--}
--
--int main()
--{
-- return (mytest("Hello%d\n", 1));
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of vsprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_vsprintf_void"
-- echo "Checking for return value of vsprintf()... No."
-- echo " WARNING: apparently vsprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- fi
--else
-- echo "Checking whether to use vs[n]printf() or s[n]printf()... using s[n]printf()"
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- snprintf(buf, sizeof(buf), "%s", "foo");
-- return 0;
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-- echo "Checking for snprintf() in stdio.h... Yes."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- return snprintf(buf, sizeof(buf), "%s", "foo");
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of snprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_snprintf_void"
-- echo "Checking for return value of snprintf()... No."
-- echo " WARNING: apparently snprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- else
-- CFLAGS="$CFLAGS -DNO_snprintf"
-- echo "Checking for snprintf() in stdio.h... No."
-- echo " WARNING: snprintf() not found, falling back to sprintf(). zlib"
-- echo " can build but will be open to possible buffer-overflow security"
-- echo " vulnerabilities."
--
-- cat >$test.c <<EOF
--#include <stdio.h>
--
--int mytest()
--{
-- char buf[20];
--
-- return sprintf(buf, "%s", "foo");
--}
--
--int main()
--{
-- return (mytest());
--}
--EOF
--
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for return value of sprintf()... Yes."
-- else
-- CFLAGS="$CFLAGS -DHAS_sprintf_void"
-- echo "Checking for return value of sprintf()... No."
-- echo " WARNING: apparently sprintf() does not return a value. zlib"
-- echo " can build but will be open to possible string-format security"
-- echo " vulnerabilities."
-- fi
-- fi
--fi
--
--cat >$test.c <<EOF
--#include <errno.h>
--int main() { return 0; }
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- echo "Checking for errno.h... Yes."
--else
-- echo "Checking for errno.h... No."
-- CFLAGS="$CFLAGS -DNO_ERRNO_H"
--fi
--
--cat > $test.c <<EOF
--#include <sys/types.h>
--#include <sys/mman.h>
--#include <sys/stat.h>
--caddr_t hello() {
-- return mmap((caddr_t)0, (off_t)0, PROT_READ, MAP_SHARED, 0, (off_t)0);
--}
--EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-- CFLAGS="$CFLAGS -DUSE_MMAP"
-- echo Checking for mmap support... Yes.
--else
-- echo Checking for mmap support... No.
--fi
--
--CPP=${CPP-"$CC -E"}
--case $CFLAGS in
-- *ASMV*)
-- if test "`nm $test.o | grep _hello`" = ""; then
-- CPP="$CPP -DNO_UNDERLINE"
-- echo Checking for underline in external names... No.
-- else
-- echo Checking for underline in external names... Yes.
-- fi;;
--esac
--
--rm -f $test.[co] $test $test$shared_ext
--
--# udpate Makefile
--sed < Makefile.in "
--/^CC *=/s#=.*#=$CC#
--/^CFLAGS *=/s#=.*#=$CFLAGS#
--/^CPP *=/s#=.*#=$CPP#
--/^LDSHARED *=/s#=.*#=$LDSHARED#
--/^LIBS *=/s#=.*#=$LIBS#
--/^SHAREDLIB *=/s#=.*#=$SHAREDLIB#
--/^SHAREDLIBV *=/s#=.*#=$SHAREDLIBV#
--/^SHAREDLIBM *=/s#=.*#=$SHAREDLIBM#
--/^AR *=/s#=.*#=$AR#
--/^RANLIB *=/s#=.*#=$RANLIB#
--/^EXE *=/s#=.*#=$EXE#
--/^prefix *=/s#=.*#=$prefix#
--/^exec_prefix *=/s#=.*#=$exec_prefix#
--/^libdir *=/s#=.*#=$libdir#
--/^includedir *=/s#=.*#=$includedir#
--/^mandir *=/s#=.*#=$mandir#
--/^LDFLAGS *=/s#=.*#=$LDFLAGS#
--" > Makefile
-diff -Naur zlib-1.2.3/configure.ac zlib-1.2.3new/configure.ac
---- zlib-1.2.3/configure.ac 1970-01-01 01:00:00.000000000 +0100
-+++ zlib-1.2.3new/configure.ac 2006-08-07 20:38:31.612402750 +0200
-@@ -0,0 +1,17 @@
-+AC_INIT(zlib,1.2.3)
-+AC_CONFIG_SRCDIR(adler32.c)
-+AM_INIT_AUTOMAKE(zlibs,1.2.3)
-+
-+AC_PREREQ([2.59])
-+
-+AC_PROG_CC([gcc])
-+AC_PROG_LIBTOOL
-+
-+AC_HEADER_STDC
-+
-+AC_CONFIG_FILES([
-+Makefile
-+zlib.pc
-+])
-+
-+AC_OUTPUT
-diff -Naur zlib-1.2.3/Makefile.am zlib-1.2.3new/Makefile.am
---- zlib-1.2.3/Makefile.am 2006/10/14 05:35:40 1.1
-+++ zlib-1.2.3new/Makefile.am 2006/10/14 05:36:49
-@@ -0,0 +1,11 @@
-+lib_LTLIBRARIES = libz.la
-+
-+libz_la_SOURCES = adler32.c compress.c crc32.c gzio.c uncompr.c deflate.c \
-+ trees.c zutil.c inflate.c infback.c inftrees.c inffast.c
-+
-+libz_la_LDFLAGS = -version-number 1:2:3
-+
-+include_HEADERS = zconf.h zlib.h
-+
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = zlib.pc
-diff -Naur zlib-1.2.3/Makefile.in zlib-1.2.3new/Makefile.in
---- zlib-1.2.3/Makefile.in 2005-07-18 04:25:21.000000000 +0200
-+++ zlib-1.2.3new/Makefile.in 1970-01-01 01:00:00.000000000 +0100
-@@ -1,154 +0,0 @@
--# Makefile for zlib
--# Copyright (C) 1995-2005 Jean-loup Gailly.
--# For conditions of distribution and use, see copyright notice in zlib.h
--
--# To compile and test, type:
--# ./configure; make test
--# The call of configure is optional if you don't have special requirements
--# If you wish to build zlib as a shared library, use: ./configure -s
--
--# To use the asm code, type:
--# cp contrib/asm?86/match.S ./match.S
--# make LOC=-DASMV OBJA=match.o
--
--# To install /usr/local/lib/libz.* and /usr/local/include/zlib.h, type:
--# make install
--# To install in $HOME instead of /usr/local, use:
--# make install prefix=$HOME
--
--CC=cc
--
--CFLAGS=-O
--#CFLAGS=-O -DMAX_WBITS=14 -DMAX_MEM_LEVEL=7
--#CFLAGS=-g -DDEBUG
--#CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \
--# -Wstrict-prototypes -Wmissing-prototypes
--
--LDFLAGS=libz.a
--LDSHARED=$(CC)
--CPP=$(CC) -E
--
--LIBS=libz.a
--SHAREDLIB=libz.so
--SHAREDLIBV=libz.so.1.2.3
--SHAREDLIBM=libz.so.1
--
--AR=ar rc
--RANLIB=ranlib
--TAR=tar
--SHELL=/bin/sh
--EXE=
--
--prefix = /usr/local
--exec_prefix = ${prefix}
--libdir = ${exec_prefix}/lib
--includedir = ${prefix}/include
--mandir = ${prefix}/share/man
--man3dir = ${mandir}/man3
--
--OBJS = adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o \
-- zutil.o inflate.o infback.o inftrees.o inffast.o
--
--OBJA =
--# to use the asm code: make OBJA=match.o
--
--TEST_OBJS = example.o minigzip.o
--
--all: example$(EXE) minigzip$(EXE)
--
--check: test
--test: all
-- @LD_LIBRARY_PATH=.:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
-- echo hello world | ./minigzip | ./minigzip -d || \
-- echo ' *** minigzip test FAILED ***' ; \
-- if ./example; then \
-- echo ' *** zlib test OK ***'; \
-- else \
-- echo ' *** zlib test FAILED ***'; \
-- fi
--
--libz.a: $(OBJS) $(OBJA)
-- $(AR) $@ $(OBJS) $(OBJA)
-- -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
--
--match.o: match.S
-- $(CPP) match.S > _match.s
-- $(CC) -c _match.s
-- mv _match.o match.o
-- rm -f _match.s
--
--$(SHAREDLIBV): $(OBJS)
-- $(LDSHARED) -o $@ $(OBJS)
-- rm -f $(SHAREDLIB) $(SHAREDLIBM)
-- ln -s $@ $(SHAREDLIB)
-- ln -s $@ $(SHAREDLIBM)
--
--example$(EXE): example.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS)
--
--minigzip$(EXE): minigzip.o $(LIBS)
-- $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
--
--install: $(LIBS)
-- -@if [ ! -d $(exec_prefix) ]; then mkdir -p $(exec_prefix); fi
-- -@if [ ! -d $(includedir) ]; then mkdir -p $(includedir); fi
-- -@if [ ! -d $(libdir) ]; then mkdir -p $(libdir); fi
-- -@if [ ! -d $(man3dir) ]; then mkdir -p $(man3dir); fi
-- cp zlib.h zconf.h $(includedir)
-- chmod 644 $(includedir)/zlib.h $(includedir)/zconf.h
-- cp $(LIBS) $(libdir)
-- cd $(libdir); chmod 755 $(LIBS)
-- -@(cd $(libdir); $(RANLIB) libz.a || true) >/dev/null 2>&1
-- cd $(libdir); if test -f $(SHAREDLIBV); then \
-- rm -f $(SHAREDLIB) $(SHAREDLIBM); \
-- ln -s $(SHAREDLIBV) $(SHAREDLIB); \
-- ln -s $(SHAREDLIBV) $(SHAREDLIBM); \
-- (ldconfig || true) >/dev/null 2>&1; \
-- fi
-- cp zlib.3 $(man3dir)
-- chmod 644 $(man3dir)/zlib.3
--# The ranlib in install is needed on NeXTSTEP which checks file times
--# ldconfig is for Linux
--
--uninstall:
-- cd $(includedir); \
-- cd $(libdir); rm -f libz.a; \
-- if test -f $(SHAREDLIBV); then \
-- rm -f $(SHAREDLIBV) $(SHAREDLIB) $(SHAREDLIBM); \
-- fi
-- cd $(man3dir); rm -f zlib.3
--
--mostlyclean: clean
--clean:
-- rm -f *.o *~ example$(EXE) minigzip$(EXE) \
-- libz.* foo.gz so_locations \
-- _match.s maketree contrib/infback9/*.o
--
--maintainer-clean: distclean
--distclean: clean
-- cp -p Makefile.in Makefile
-- cp -p zconf.in.h zconf.h
-- rm -f .DS_Store
--
--tags:
-- etags *.[ch]
--
--depend:
-- makedepend -- $(CFLAGS) -- *.[ch]
--
--# DO NOT DELETE THIS LINE -- make depend depends on it.
--
--adler32.o: zlib.h zconf.h
--compress.o: zlib.h zconf.h
--crc32.o: crc32.h zlib.h zconf.h
--deflate.o: deflate.h zutil.h zlib.h zconf.h
--example.o: zlib.h zconf.h
--gzio.o: zutil.h zlib.h zconf.h
--inffast.o: zutil.h zlib.h zconf.h inftrees.h inflate.h inffast.h
--inflate.o: zutil.h zlib.h zconf.h inftrees.h inflate.h inffast.h
--infback.o: zutil.h zlib.h zconf.h inftrees.h inflate.h inffast.h
--inftrees.o: zutil.h zlib.h zconf.h inftrees.h
--minigzip.o: zlib.h zconf.h
--trees.o: deflate.h zutil.h zlib.h zconf.h trees.h
--uncompr.o: zlib.h zconf.h
--zutil.o: zutil.h zlib.h zconf.h
-diff -Naur zlib-1.2.3/zlib.pc.in zlib-1.2.3New/zlib.pc.in
---- zlib-1.2.3/zlib.pc.in 1970-01-01 01:00:00.000000000 +0100
-+++ zlib-1.2.3New/zlib.pc.in 2006-12-07 10:55:45.000000000 +0100
-@@ -0,0 +1,10 @@
-+prefix=@prefix@
-+exec_prefix=@exec_prefix@
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: zlib
-+Description: Standard (de)compression library
-+Version: @VERSION@
-+Libs: -L${libdir} -lz
-+Cflags: -I${includedir}
-