summaryrefslogtreecommitdiff
path: root/packages/zcip
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/zcip
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/zcip')
-rw-r--r--packages/zcip/zcip-4/char-signed-idiocy.patch16
-rw-r--r--packages/zcip/zcip-4/compile.patch125
-rw-r--r--packages/zcip/zcip-4/linux-types.patch15
-rw-r--r--packages/zcip/zcip_4.bb18
4 files changed, 0 insertions, 174 deletions
diff --git a/packages/zcip/zcip-4/char-signed-idiocy.patch b/packages/zcip/zcip-4/char-signed-idiocy.patch
deleted file mode 100644
index 109efc2349..0000000000
--- a/packages/zcip/zcip-4/char-signed-idiocy.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/zcip.c~char-signed-idiocy
-+++ zcip-4/zcip.c
-@@ -1243,7 +1243,7 @@
-
- int main(int argc, char *argv[]) {
- int r, rand_seed = 0;
-- char c;
-+ int c;
- char ebuf[LIBNET_ERRBUF_SIZE];
-
- struct option longopts[] = {
diff --git a/packages/zcip/zcip-4/compile.patch b/packages/zcip/zcip-4/compile.patch
deleted file mode 100644
index a8cfa32cd8..0000000000
--- a/packages/zcip/zcip-4/compile.patch
+++ /dev/null
@@ -1,125 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/Makefile~compile
-+++ zcip-4/Makefile
-@@ -5,21 +5,17 @@
- CPPFLAGS=`libnet-config --cflags` `libnet-config --defines`
- CFLAGS=-O2 -Wall -W -I/usr/local/contrib/include -I/usr/local/include/pcap
- LDFLAGS=-L/usr/local/contrib/lib -L/usr/local/lib -static
--
--
-+LIBS=-lpcap `libnet-config --libs`
- OBJS=zcip.o
-
--
--
--
- all: zcip make-arp
-
-
- make-arp: make-arp.o
-- $(CC) make-arp.o $(LDFLAGS) -o make-arp -lpcap `libnet-config --libs`
-+ $(CC) make-arp.o $(LDFLAGS) -o make-arp $(LIBS)
-
- zcip: $(OBJS)
-- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip -lpcap `libnet-config --libs`
-+ $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip $(LIBS)
-
-
- clean:
---- zcip-4/zcip.c~compile
-+++ zcip-4/zcip.c
-@@ -1204,14 +1204,14 @@
- }
-
- void version(void) {
-- printf("zcip release " RELEASE "
--Copyright (C) 2001-2002 Various authors
--zcip comes with NO WARRANTY,
--to the extent permitted by law.
--You may redistribute copies of zcip
--under the terms of the 3-clause BSD license.
--For more information about these matters,
--see the file named Copyright.
-+ printf("zcip release " RELEASE "\n\
-+Copyright (C) 2001-2002 Various authors\n\
-+zcip comes with NO WARRANTY,\n\
-+to the extent permitted by law.\n\
-+You may redistribute copies of zcip\n\
-+under the terms of the 3-clause BSD license.\n\
-+For more information about these matters,\n\
-+see the file named Copyright.\n\
- ");
-
- exit (0);
-@@ -1219,19 +1219,19 @@
-
-
- void usage(int exit_code) {
-- printf("usage: zcip [OPTIONS]
--Zeroconf IPv4 Link-Local Address Configuration
--OPTIONS:
-- -h, --help Print this help, and exit.
-- -i, --interface IFNAME Use interface IFNAME.
-- If not provided it uses 'eth0'.
-- -r, --randseed Seeds RNG with random # rather than MAC address.
-- -s, --syslog Output to syslog instead of stdout.
-- -v, --version Print the version information, and exit.
--
--This program does the ad-hoc link-local IPv4 auto-configuration trick, as
--described in the IETF Internet Draft 'Dynamic Configuration of IPv4
--Link-Local Addresses'.
-+ printf("usage: zcip [OPTIONS]\n\
-+Zeroconf IPv4 Link-Local Address Configuration\n\
-+OPTIONS:\n\
-+ -h, --help Print this help, and exit.\n\
-+ -i, --interface IFNAME Use interface IFNAME.\n\
-+ If not provided it uses 'eth0'.\n\
-+ -r, --randseed Seeds RNG with random # rather than MAC address.\n\
-+ -s, --syslog Output to syslog instead of stdout.\n\
-+ -v, --version Print the version information, and exit.\n\
-+\n\
-+This program does the ad-hoc link-local IPv4 auto-configuration trick, as\n\
-+described in the IETF Internet Draft 'Dynamic Configuration of IPv4\n\
-+Link-Local Addresses'.\n\
- ");
-
- exit (exit_code);
---- zcip-4/make-arp.c~compile
-+++ zcip-4/make-arp.c
-@@ -106,19 +106,19 @@
-
-
- void usage(int exit_code) {
-- printf("
--make-arp -- sends arbitrary ARP Requests
--
--usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP
--
--OPTIONS:
--
-- -h Print this help.
--
--
--Only ARP Requests for now. In the Ethernet header, the source EA is
--mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.
--
-+ printf("\n\
-+make-arp -- sends arbitrary ARP Requests\n\
-+\n\
-+usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP\n\
-+\n\
-+OPTIONS:\n\
-+\n\
-+ -h Print this help.\n\
-+\n\
-+\n\
-+Only ARP Requests for now. In the Ethernet header, the source EA is\n\
-+mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.\n\
-+\n\
- ");
-
- exit (exit_code);
diff --git a/packages/zcip/zcip-4/linux-types.patch b/packages/zcip/zcip-4/linux-types.patch
deleted file mode 100644
index 5ca388cafc..0000000000
--- a/packages/zcip/zcip-4/linux-types.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- zcip-4/zcip.c~linux-types
-+++ zcip-4/zcip.c
-@@ -163,6 +163,7 @@
- #endif
-
- #ifdef CHECK_KERNEL_SOCKETFILTERS
-+#include <linux/types.h>
- #include <linux/filter.h>
-
- //
diff --git a/packages/zcip/zcip_4.bb b/packages/zcip/zcip_4.bb
deleted file mode 100644
index ca0405ca6d..0000000000
--- a/packages/zcip/zcip_4.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SECTION = "console/network"
-DEPENDS = "libpcap libnet-1.0.2a"
-DESCRIPTION = "zcip is an implementation of zero configuration networking (zeroconf)."
-LICENSE = "BSD"
-SRC_URI = "${SOURCEFORGE_MIRROR}/zeroconf/zcip-${PV}.tar.gz \
- file://compile.patch;patch=1 \
- file://linux-types.patch;patch=1 \
- file://char-signed-idiocy.patch;patch=1"
-
-CPPFLAGS_append = " -DLIBNET_LIL_ENDIAN"
-do_compile () {
- oe_runmake 'LIBS=${STAGING_LIBDIR}/libpcap.a ${STAGING_LIBDIR}/libnet.a'
-}
-
-do_install () {
- install -d ${D}${sbindir}
- install -m 0744 make-arp zcip ${D}${sbindir}/
-}