summaryrefslogtreecommitdiff
path: root/packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-09-08 20:10:15 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-09-08 20:10:15 +0000
commit3317f53154cb592cb4f35caf5d854c404d7d20c1 (patch)
tree24973af3dd6c7afb4614cd7d545db82e999bcb93 /packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch
parent0993eafefdb4f1d5295173635127a67e01426f30 (diff)
xserver-kdrive: add 1.4 for X11R7.3 release
* The tslib mouse driver has to be selected with "-mouse tslib", it defaults to the /dev/input/touchscreen0 evdev device in this build. * The evdev keyboard driver is available, but not very useful yet. It doesn't accept any command line options as long as XKB is disabled. * xcalibrate and tslib are taped together with a bit of ugly code in xcalibrate-new-input-world-order.patch. This should be replaced as soon as I learn how to do it correctly.
Diffstat (limited to 'packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch')
-rw-r--r--packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch b/packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch
new file mode 100644
index 0000000000..3746be5f53
--- /dev/null
+++ b/packages/xorg-xserver/xserver-kdrive-1.4/enable-tslib.patch
@@ -0,0 +1,24 @@
+Index: xorg-server-1.4/configure.ac
+===================================================================
+--- xorg-server-1.4.orig/configure.ac 2007-09-08 16:36:37.000000000 +0200
++++ xorg-server-1.4/configure.ac 2007-09-08 16:38:10.000000000 +0200
+@@ -1816,7 +1816,7 @@
+ AC_CHECK_LIB([rt], [nanosleep], XEPHYR_LIBS="$XEPHYR_LIBS -lrt"))
+
+ if test "x$TSLIB" = xyes; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
+ if test "x$HAVE_TSLIB" = xno; then
+ AC_MSG_ERROR([tslib must be installed to build the tslib driver. See http://tslib.berlios.de/])
+ fi
+@@ -1840,8 +1840,8 @@
+ ;;
+ esac
+ KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
+- KDRIVE_LOCAL_LIBS="$DIX_LIB $CONFIG_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
+- KDRIVE_LIBS="$XSERVERLIBS_LIBS $KDRIVE_LOCAL_LIBS"
++ KDRIVE_LOCAL_LIBS="$DIX_LIB $CONFIG_LIB $KDRIVE_LIB $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
++ KDRIVE_LIBS="$XSERVERLIBS_LIBS $TSLIB_LIBS $KDRIVE_LOCAL_LIBS"
+
+ # check if we can build Xephyr
+ PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])