summaryrefslogtreecommitdiff
path: root/packages/xorg-lib/libxvmc_20040919.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 19:46:41 +0000
commitdd0c887b669ed5f2fdfa21118f4b32d096e92816 (patch)
tree52a9bb766480ea9983a6e3e5d4ae600e0a482f2c /packages/xorg-lib/libxvmc_20040919.bb
parentb88c8ee5fdd3c5bda8a7fea778c3d7b09b180622 (diff)
xorg-*: Massive rename to conform to X11R7.x_a.b.c versioning and xorg-* directory structure.
This is the first step for the update to X11R7.1. This will not build and will be followed by more patches and updates.
Diffstat (limited to 'packages/xorg-lib/libxvmc_20040919.bb')
-rw-r--r--packages/xorg-lib/libxvmc_20040919.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/xorg-lib/libxvmc_20040919.bb b/packages/xorg-lib/libxvmc_20040919.bb
new file mode 100644
index 0000000000..b70c9f52e4
--- /dev/null
+++ b/packages/xorg-lib/libxvmc_20040919.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "X Video Motion Compensation extension library."
+SECTION = "x11/libs"
+DEPENDS = "libx11 libxext libxv drm xserver-xorg"
+PR = "r2"
+
+SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=XvMC;date=${PV};method=pserver \
+ cvs://anonymous@cvs.sourceforge.net/cvsroot/unichrome;module=libxvmc;date=${PV};method=pserver \
+ file://via.patch;patch=1 \
+ file://true.patch"
+S = "${WORKDIR}/XvMC"
+
+CFLAGS += "-I${STAGING_INCDIR}/X11/extensions -I${STAGING_INCDIR}/xserver-xorg"
+
+# this one is for via only atm.
+COMPATIBLE_HOST = 'i.86.*-linux'
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ install -d ${S}/hw/via
+ cp ${WORKDIR}/libxvmc/*.[ch] ${S}/hw/via/
+ ( cd ${S}/hw/via ; patch < ${WORKDIR}/true.patch )
+}
+
+do_compile() {
+ oe_runmake
+ oe_runmake -C hw/via
+}
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DATADIR}/man
+ oe_libinstall -so -C hw/via libviaXvMC ${STAGING_LIBDIR}
+ install hw/via/vldXvMC.h ${STAGING_INCDIR}/X11/extensions/
+}