summaryrefslogtreecommitdiff
path: root/packages/xlibs/libxfont
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-02 17:54:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-02 17:54:35 +0000
commit40ce95ca64d662c16cec3d1efabc966dda5a2610 (patch)
treec5687492fbbc7f7e46b8db8448b1da640fef9955 /packages/xlibs/libxfont
parent858ca7bc53e7c03eac036217486e87e36eb1e3e6 (diff)
parent966f3a94af2c83ffd2c634171fbe04917731b6f9 (diff)
explicit_merge of '601faaded8a6427e29dc8dc43433fe9be662c96c'
and 'a67386ccbaf4538441ab5d8769e018207ab0c744' using ancestor '9c1b32d8825be71ddfdcbe3ddfa31b4cc8bb2aa0' to branch 'org.openembedded.dev'
Diffstat (limited to 'packages/xlibs/libxfont')
-rw-r--r--packages/xlibs/libxfont/.mtn2git_empty0
-rw-r--r--packages/xlibs/libxfont/autofoo.patch18
-rw-r--r--packages/xlibs/libxfont/scalable.patch27
3 files changed, 45 insertions, 0 deletions
diff --git a/packages/xlibs/libxfont/.mtn2git_empty b/packages/xlibs/libxfont/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xlibs/libxfont/.mtn2git_empty
diff --git a/packages/xlibs/libxfont/autofoo.patch b/packages/xlibs/libxfont/autofoo.patch
new file mode 100644
index 0000000000..4998625c24
--- /dev/null
+++ b/packages/xlibs/libxfont/autofoo.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libXfont-1.4.2/configure.ac~autofoo 2004-05-06 20:19:03.000000000 -0400
++++ libXfont-1.4.2/configure.ac 2005-01-16 12:14:14.042598720 -0500
+@@ -35,9 +35,9 @@
+ dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
+ dnl not possible to extract the version number here from Xfont.h
+ dnl
++AC_CONFIG_AUX_DIR(.)
+ AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_CONFIG_HEADER(config.h)
+-AC_CONFIG_AUX_DIR(.)
+ AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h])
+
+ # Check for progs
diff --git a/packages/xlibs/libxfont/scalable.patch b/packages/xlibs/libxfont/scalable.patch
new file mode 100644
index 0000000000..7f97b9a8f6
--- /dev/null
+++ b/packages/xlibs/libxfont/scalable.patch
@@ -0,0 +1,27 @@
+Index: fontfile/fontdir.c
+===================================================================
+RCS file: /cvs/xlibs/Xfont/fontfile/fontdir.c,v
+retrieving revision 3.22
+diff -u -r3.22 fontdir.c
+--- xfont/fontfile/fontdir.c 7 Jul 2003 16:40:11 -0000 3.22
++++ xfont/fontfile/fontdir.c 30 Dec 2004 20:37:12 -0000
+@@ -699,6 +699,11 @@
+ */
+ if (isscale)
+ {
++ /* If the fontname says it is scalable, make sure that the
++ * renderer supports OpenScalable and GetInfoScalable.
++ */
++ if (renderer->OpenScalable && renderer->GetInfoScalable)
++ {
+ if (vals.values_supplied & SIZE_SPECIFY_MASK)
+ {
+ bzero((char *)&zeroVals, sizeof(zeroVals));
+@@ -798,6 +803,7 @@
+ bitmap->name.name);
+ }
+ }
++ }
+ }
+ return TRUE;
+ }