summaryrefslogtreecommitdiff
path: root/packages/xlibs/libx11_6.2.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-02 17:54:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-02 17:54:35 +0000
commit40ce95ca64d662c16cec3d1efabc966dda5a2610 (patch)
treec5687492fbbc7f7e46b8db8448b1da640fef9955 /packages/xlibs/libx11_6.2.1.bb
parent858ca7bc53e7c03eac036217486e87e36eb1e3e6 (diff)
parent966f3a94af2c83ffd2c634171fbe04917731b6f9 (diff)
explicit_merge of '601faaded8a6427e29dc8dc43433fe9be662c96c'
and 'a67386ccbaf4538441ab5d8769e018207ab0c744' using ancestor '9c1b32d8825be71ddfdcbe3ddfa31b4cc8bb2aa0' to branch 'org.openembedded.dev'
Diffstat (limited to 'packages/xlibs/libx11_6.2.1.bb')
-rw-r--r--packages/xlibs/libx11_6.2.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/xlibs/libx11_6.2.1.bb b/packages/xlibs/libx11_6.2.1.bb
new file mode 100644
index 0000000000..ac3cce8bd7
--- /dev/null
+++ b/packages/xlibs/libx11_6.2.1.bb
@@ -0,0 +1,41 @@
+SECTION = "x11/libs"
+LICENSE = "XFree86"
+PRIORITY = "optional"
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+DEPENDS = "xproto xextensions libxau xtrans libxdmcp"
+PROVIDES = "x11"
+DESCRIPTION = "Base X libs."
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB"
+FILES_${PN}-locale += "${datadir}/X11/locale"
+PROVIDES = "libx11"
+PR = "r4"
+
+SRC_URI = "${XLIBS_MIRROR}/libX11-${PV}.tar.bz2 \
+ file://errordb-keysymdb-path-fix.patch;patch=1 \
+ file://autofoo.patch;patch=1"
+S = "${WORKDIR}/libX11-${PV}"
+
+inherit autotools pkgconfig
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD
+# unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake -C src/util 'CFLAGS= -D_GNU_SOURCE' 'LDFLAGS=' 'CXXFLAGS=' 'CPPFLAGS=' makekeys
+ )
+ oe_runmake
+}
+
+do_stage() {
+ install -c -m 644 include/X11/XKBlib.h ${STAGING_INCDIR}/X11/XKBlib.h
+ install -c -m 644 include/X11/Xcms.h ${STAGING_INCDIR}/X11/Xcms.h
+ install -c -m 644 include/X11/Xlib.h ${STAGING_INCDIR}/X11/Xlib.h
+ install -c -m 644 include/X11/Xlibint.h ${STAGING_INCDIR}/X11/Xlibint.h
+ install -c -m 644 include/X11/Xlocale.h ${STAGING_INCDIR}/X11/Xlocale.h
+ install -c -m 644 include/X11/Xresource.h ${STAGING_INCDIR}/X11/Xresource.h
+ install -c -m 644 include/X11/Xutil.h ${STAGING_INCDIR}/X11/Xutil.h
+ install -c -m 644 include/X11/cursorfont.h ${STAGING_INCDIR}/X11/cursorfont.h
+ install -c -m 644 include/X11/region.h ${STAGING_INCDIR}/X11/region.h
+
+ oe_libinstall -a -so -C src libX11 ${STAGING_LIBDIR}
+}