summaryrefslogtreecommitdiff
path: root/packages/xkbd/xkbd-0.8.15
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/xkbd/xkbd-0.8.15
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/xkbd/xkbd-0.8.15')
-rw-r--r--packages/xkbd/xkbd-0.8.15/add-default-common-slides.patch44
-rw-r--r--packages/xkbd/xkbd-0.8.15/differentiate-desktop-name.patch12
-rw-r--r--packages/xkbd/xkbd-0.8.15/fix-circumkey.patch18
-rw-r--r--packages/xkbd/xkbd-0.8.15/fix-equalsign.patch24
-rw-r--r--packages/xkbd/xkbd-0.8.15/libtool-lossage.patch43
-rw-r--r--packages/xkbd/xkbd-0.8.15/xkbd.pngbin3385 -> 0 bytes
6 files changed, 0 insertions, 141 deletions
diff --git a/packages/xkbd/xkbd-0.8.15/add-default-common-slides.patch b/packages/xkbd/xkbd-0.8.15/add-default-common-slides.patch
deleted file mode 100644
index 0423ee1eed..0000000000
--- a/packages/xkbd/xkbd-0.8.15/add-default-common-slides.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -r 6b20ef8fbdee src/kb.c
---- a/src/kb.c Tue Nov 27 21:28:21 2007 +0200
-+++ b/src/kb.c Tue Nov 27 22:27:09 2007 +0200
-@@ -954,6 +954,13 @@ void kb_send_keypress(button *b)
- int slide_flag = 0;
-
- struct keycodeEntry vk_keycodes[10];
-+
-+ static KeySym ksSpace, ksBackSpace, ksReturn;
-+ if (!ksSpace) {
-+ ksSpace = XStringToKeysym("space");
-+ ksBackSpace = XStringToKeysym("BackSpace");
-+ ksReturn = XStringToKeysym("Return");
-+ }
-
- if (b->kb->state & KB_STATE_SHIFT || b->kb->state & KB_STATE_CAPS)
- {
-@@ -981,20 +988,17 @@ void kb_send_keypress(button *b)
- ks = b->slide_up_ks;
- if (ks == 0) ks = b->shift_ks;
- break;
-- case down : /* hold ctrl */
-+ case down :
- ks = b->slide_down_ks;
-- if (ks == 0) slide_flag = KB_STATE_CTRL;
-+ if (ks == 0) ks = ksReturn;
- break;
-- case left : /* hold alt */
-+ case left :
- ks = b->slide_left_ks;
-- if (ks == 0)
-- {
-- ks = b->mod_ks;
-- slide_flag = KB_STATE_MOD;
-- }
-+ if (ks == 0) ks = ksBackSpace;
- break;
-- case right : /* hold alt */
-+ case right :
- ks = b->slide_right_ks;
-+ if (ks == 0) ks = ksSpace;
- break;
- case none:
- break;
diff --git a/packages/xkbd/xkbd-0.8.15/differentiate-desktop-name.patch b/packages/xkbd/xkbd-0.8.15/differentiate-desktop-name.patch
deleted file mode 100644
index 60617a671c..0000000000
--- a/packages/xkbd/xkbd-0.8.15/differentiate-desktop-name.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r 1eb4100bbe39 xkbd.desktop
---- a/xkbd.desktop Wed Nov 28 02:14:35 2007 +0200
-+++ b/xkbd.desktop Wed Nov 28 02:15:01 2007 +0200
-@@ -1,6 +1,6 @@
- [Desktop Entry]
--Name=Keyboard
--Comment=Virtual Keyboard
-+Name=Ol' Good Keyboard
-+Comment=xkbd the Virtual Keyboard
- Exec=xkbd
- Type=Application
- Icon=xkbd.png
diff --git a/packages/xkbd/xkbd-0.8.15/fix-circumkey.patch b/packages/xkbd/xkbd-0.8.15/fix-circumkey.patch
deleted file mode 100644
index b23a2a3f9f..0000000000
--- a/packages/xkbd/xkbd-0.8.15/fix-circumkey.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- xkbd-0.8.15.orig/data/en_GB.qwerty.xkbd.in 2006-03-09 14:48:09.000000000 +0100
-+++ xkbd-0.8.15/data/en_GB.qwerty.xkbd.in 2006-03-09 14:52:36.000000000 +0100
-@@ -95,7 +95,7 @@
- default 6
- default_ks 6
- shift ^
-- shift_ks numbersign
-+ shift_ks asciicircum
- </key>
- <key>
- default 7
-@@ -438,4 +438,4 @@
- shift_ks Control_R
- </key>
- </row>
--</layout>
-\ No newline at end of file
-+</layout>
diff --git a/packages/xkbd/xkbd-0.8.15/fix-equalsign.patch b/packages/xkbd/xkbd-0.8.15/fix-equalsign.patch
deleted file mode 100644
index dac0a60f2c..0000000000
--- a/packages/xkbd/xkbd-0.8.15/fix-equalsign.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -upr xkbd-0.8.15.orig/data/en_GB.qwerty.tabletpc.xkbd.in xkbd-0.8.15/data/en_GB.qwerty.tabletpc.xkbd.in
---- xkbd-0.8.15.orig/data/en_GB.qwerty.tabletpc.xkbd.in 2003-06-30 19:58:35.000000000 +0100
-+++ xkbd-0.8.15/data/en_GB.qwerty.tabletpc.xkbd.in 2006-02-04 10:59:19.000000000 +0000
-@@ -131,7 +131,7 @@ button_style rounded
- default +
- default_ks plus
- shift =
-- shift_ks KP_Equal
-+ shift_ks equal
- </key>
- <key>
- default <--
-diff -upr xkbd-0.8.15.orig/data/en_GB.qwerty.xkbd.in xkbd-0.8.15/data/en_GB.qwerty.xkbd.in
---- xkbd-0.8.15.orig/data/en_GB.qwerty.xkbd.in 2003-08-10 18:46:29.000000000 +0100
-+++ xkbd-0.8.15/data/en_GB.qwerty.xkbd.in 2006-02-04 10:59:10.000000000 +0000
-@@ -131,7 +131,7 @@ button_style square
- default +
- default_ks plus
- shift =
-- shift_ks KP_Equal
-+ shift_ks equal
- </key>
- <key>
- img @pkgdatadir@/img/backspace.xpm
diff --git a/packages/xkbd/xkbd-0.8.15/libtool-lossage.patch b/packages/xkbd/xkbd-0.8.15/libtool-lossage.patch
deleted file mode 100644
index 2d1b7dbe5d..0000000000
--- a/packages/xkbd/xkbd-0.8.15/libtool-lossage.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- clean/xkbd-0.8.12/configure.ac 2003-06-03 17:27:20.000000000 +0100
-+++ xkbd-0.8.12/configure.ac 2004-03-28 19:35:33.000000000 +0100
-@@ -46,11 +46,11 @@
- CFLAGS="$CFLAGS -g -DDEBUG"
- fi])
-
-+PKG_CHECK_MODULES(XTEST, xtst xext)
-
- # Checks for programs.
- AC_PROG_CC
- AC_PROG_INSTALL
--AC_PROG_LIBTOOL
-
- # Checks for libraries.
-
-@@ -70,6 +70,8 @@
-
- AC_SUBST(XFT_LIBS)
- AC_SUBST(XPM_LIBS)
-+AC_SUBST(XTEST_LIBS)
-+AC_SUBST(XTEST_CFLAGS)
-
- AC_OUTPUT(Makefile
- src/Makefile
-@@ -78,4 +80,4 @@
- data/img/Makefile
- packaging/Makefile
- packaging/ipkg/Makefile
-- packaging/ipkg/control )
-\ No newline at end of file
-+ packaging/ipkg/control )
---- clean/xkbd-0.8.12/src/Makefile.am 2003-06-03 17:31:07.000000000 +0100
-+++ xkbd-0.8.12/src/Makefile.am 2004-03-28 19:34:39.000000000 +0100
-@@ -1,7 +1,7 @@
- DEFAULT_CONFIG=$(pkgdatadir)/en_GB.qwerty.xkbd
-
--LDADD = @X_LIBS@ -lX11 -lXtst $(XPM_LIBS) $(XFT_LIBS)
--CFLAGS = @CFLAGS@ -DDEFAULTCONFIG=\"$(DEFAULT_CONFIG)\"
-+LDADD = @XTEST_LIBS@ $(XPM_LIBS) $(XFT_LIBS)
-+AM_CFLAGS = @XTEST_CFLAGS@ @CFLAGS@ -DDEFAULTCONFIG=\"$(DEFAULT_CONFIG)\"
-
- bin_PROGRAMS = xkbd
- xkbd_SOURCES = xkbd.c libXkbd.c box.c button.c kb.c libvirtkeys.c \
diff --git a/packages/xkbd/xkbd-0.8.15/xkbd.png b/packages/xkbd/xkbd-0.8.15/xkbd.png
deleted file mode 100644
index 3304a77e7b..0000000000
--- a/packages/xkbd/xkbd-0.8.15/xkbd.png
+++ /dev/null
Binary files differ