summaryrefslogtreecommitdiff
path: root/packages/xfont
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/xfont
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/xfont')
-rw-r--r--packages/xfont/.mtn2git_empty0
-rw-r--r--packages/xfont/files/.mtn2git_empty0
-rw-r--r--packages/xfont/files/autofoo.patch18
-rw-r--r--packages/xfont/files/scalable.patch27
4 files changed, 45 insertions, 0 deletions
diff --git a/packages/xfont/.mtn2git_empty b/packages/xfont/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xfont/.mtn2git_empty
diff --git a/packages/xfont/files/.mtn2git_empty b/packages/xfont/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xfont/files/.mtn2git_empty
diff --git a/packages/xfont/files/autofoo.patch b/packages/xfont/files/autofoo.patch
index e69de29bb2..4998625c24 100644
--- a/packages/xfont/files/autofoo.patch
+++ b/packages/xfont/files/autofoo.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libXfont-1.4.2/configure.ac~autofoo 2004-05-06 20:19:03.000000000 -0400
++++ libXfont-1.4.2/configure.ac 2005-01-16 12:14:14.042598720 -0500
+@@ -35,9 +35,9 @@
+ dnl Yes, it is a pain to synchronize version numbers. Unfortunately, it's
+ dnl not possible to extract the version number here from Xfont.h
+ dnl
++AC_CONFIG_AUX_DIR(.)
+ AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_CONFIG_HEADER(config.h)
+-AC_CONFIG_AUX_DIR(.)
+ AC_CONFIG_HEADERS([include/X11/fonts/fontconf.h])
+
+ # Check for progs
diff --git a/packages/xfont/files/scalable.patch b/packages/xfont/files/scalable.patch
index e69de29bb2..7f97b9a8f6 100644
--- a/packages/xfont/files/scalable.patch
+++ b/packages/xfont/files/scalable.patch
@@ -0,0 +1,27 @@
+Index: fontfile/fontdir.c
+===================================================================
+RCS file: /cvs/xlibs/Xfont/fontfile/fontdir.c,v
+retrieving revision 3.22
+diff -u -r3.22 fontdir.c
+--- xfont/fontfile/fontdir.c 7 Jul 2003 16:40:11 -0000 3.22
++++ xfont/fontfile/fontdir.c 30 Dec 2004 20:37:12 -0000
+@@ -699,6 +699,11 @@
+ */
+ if (isscale)
+ {
++ /* If the fontname says it is scalable, make sure that the
++ * renderer supports OpenScalable and GetInfoScalable.
++ */
++ if (renderer->OpenScalable && renderer->GetInfoScalable)
++ {
+ if (vals.values_supplied & SIZE_SPECIFY_MASK)
+ {
+ bzero((char *)&zeroVals, sizeof(zeroVals));
+@@ -798,6 +803,7 @@
+ bitmap->name.name);
+ }
+ }
++ }
+ }
+ return TRUE;
+ }