summaryrefslogtreecommitdiff
path: root/packages/xfce/xfce4-panel_4.4.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2008-06-13 19:50:50 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2008-10-17 14:08:01 -0300
commitc23266091f149ab3cd38f84d9dff998d985a4b3a (patch)
tree5df7ecbf938dc59dd430a919549e718f57c7b575 /packages/xfce/xfce4-panel_4.4.1.bb
parentf61b447ce825235a3c0bd83f8321fb6646834d5b (diff)
xfce4-panel: use a single recipe since we don't have multiple versions packaged
Diffstat (limited to 'packages/xfce/xfce4-panel_4.4.1.bb')
-rw-r--r--packages/xfce/xfce4-panel_4.4.1.bb24
1 files changed, 22 insertions, 2 deletions
diff --git a/packages/xfce/xfce4-panel_4.4.1.bb b/packages/xfce/xfce4-panel_4.4.1.bb
index d855f35f49..dadc413cae 100644
--- a/packages/xfce/xfce4-panel_4.4.1.bb
+++ b/packages/xfce/xfce4-panel_4.4.1.bb
@@ -2,5 +2,25 @@
# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see COPYING.MIT)
-FILE_PR ="r2"
-require ${PN}.inc
+DESCRIPTION = "XFCE4 Panel"
+SECTION = "x11"
+DEPENDS = "startup-notification virtual/libx11 libxfcegui4 libxfce4mcs xfce-mcs-manager libxml2"
+
+inherit pkgconfig xfce
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+
+do_stage() {
+autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGES += "${PN}-plugins ${PN}-mcs-plugins"
+FILES_${PN}-plugins += "${libdir}/xfce4/panel-plugins/*.so* \
+ ${datadir}/xfce4/panel-plugins/*.desktop"
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/"
+FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug"