summaryrefslogtreecommitdiff
path: root/packages/xev/xev_cvs.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-05 09:14:00 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-05 09:14:00 +0000
commit4640a467b83bd82261aae1799fa00d3797d169f3 (patch)
tree093b75938e59f72261a887760dcdab81f0ebb86c /packages/xev/xev_cvs.bb
parent4852eca44492d40f27b70bdfe97100ac5ffc1886 (diff)
add xev (X event viewer) - patch courtesy Justin Patrin
Diffstat (limited to 'packages/xev/xev_cvs.bb')
-rw-r--r--packages/xev/xev_cvs.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/xev/xev_cvs.bb b/packages/xev/xev_cvs.bb
new file mode 100644
index 0000000000..4d47df9e7a
--- /dev/null
+++ b/packages/xev/xev_cvs.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "X Event Viewer"
+HOMEPAGE = "http://www.xfree86.org/current/xev.1.html"
+LICENSE = "GPLv2"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+SECTION = "x11/utils"
+DEPENDS = "x11 xau"
+PR = "r0"
+
+SRC_URI = "cvs://anoncvs:anoncvs@pdx.freedesktop.org/cvs/xapps;module=xev \
+ file://diet-x11.patch;patch=1"
+S = "${WORKDIR}/xev"
+
+inherit autotools
+
+do_compile() {
+ ${CC} -o xev xev.c -lX11 -lXau -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}/usr/bin/
+ install -m 755 ${PN} ${D}/usr/bin/${PN}
+}
+
+FILES = "/usr/bin/xev"
+