summaryrefslogtreecommitdiff
path: root/packages/xdamage
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/xdamage
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/xdamage')
-rw-r--r--packages/xdamage/.mtn2git_empty0
-rw-r--r--packages/xdamage/xdamage-1.0.1/.mtn2git_empty0
-rw-r--r--packages/xdamage/xdamage-1.0.1/autofoo.patch17
-rw-r--r--packages/xdamage/xdamage/.mtn2git_empty0
-rw-r--r--packages/xdamage/xdamage/m4.patch65
5 files changed, 82 insertions, 0 deletions
diff --git a/packages/xdamage/.mtn2git_empty b/packages/xdamage/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xdamage/.mtn2git_empty
diff --git a/packages/xdamage/xdamage-1.0.1/.mtn2git_empty b/packages/xdamage/xdamage-1.0.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xdamage/xdamage-1.0.1/.mtn2git_empty
diff --git a/packages/xdamage/xdamage-1.0.1/autofoo.patch b/packages/xdamage/xdamage-1.0.1/autofoo.patch
index e69de29bb2..1e3ec45d4a 100644
--- a/packages/xdamage/xdamage-1.0.1/autofoo.patch
+++ b/packages/xdamage/xdamage-1.0.1/autofoo.patch
@@ -0,0 +1,17 @@
+Index: libXdamage-1.0.1/configure.ac
+===================================================================
+--- libXdamage-1.0.1.orig/configure.ac 2004-01-15 03:54:55.000000000 -0500
++++ libXdamage-1.0.1/configure.ac 2005-01-18 19:07:16.951430928 -0500
+@@ -33,11 +33,11 @@
+ dnl protocol, so Xfixes version l.n.m corresponds to protocol version l.n
+ dnl
+ AC_INIT(libXdamage, 1.0.1, [keithp@keithp.com], libXdamage)
++AC_CONFIG_AUX_DIR(.)
+ AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_MAINTAINER_MODE
+
+ AM_CONFIG_HEADER(config.h)
+-AC_CONFIG_AUX_DIR(.)
+
+ # Check for progs
+ AC_PROG_CC
diff --git a/packages/xdamage/xdamage/.mtn2git_empty b/packages/xdamage/xdamage/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xdamage/xdamage/.mtn2git_empty
diff --git a/packages/xdamage/xdamage/m4.patch b/packages/xdamage/xdamage/m4.patch
index e69de29bb2..393f3d13d2 100644
--- a/packages/xdamage/xdamage/m4.patch
+++ b/packages/xdamage/xdamage/m4.patch
@@ -0,0 +1,65 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null
++++ Xdamage/m4/pkg.m4
+@@ -0,0 +1,57 @@
++
++dnl PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4, action-if, action-not)
++dnl defines GSTUFF_LIBS, GSTUFF_CFLAGS, see pkg-config man page
++dnl also defines GSTUFF_PKG_ERRORS on error
++AC_DEFUN(PKG_CHECK_MODULES, [
++ succeeded=no
++
++ if test -z "$PKG_CONFIG"; then
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++ fi
++
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** The pkg-config script could not be found. Make sure it is"
++ echo "*** in your path, or set the PKG_CONFIG environment variable"
++ echo "*** to the full path to pkg-config."
++ echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
++ else
++ PKG_CONFIG_MIN_VERSION=0.9.0
++ if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
++ AC_MSG_CHECKING(for $2)
++
++ if $PKG_CONFIG --exists "$2" ; then
++ AC_MSG_RESULT(yes)
++ succeeded=yes
++
++ AC_MSG_CHECKING($1_CFLAGS)
++ $1_CFLAGS=`$PKG_CONFIG --cflags "$2"`
++ AC_MSG_RESULT($$1_CFLAGS)
++
++ AC_MSG_CHECKING($1_LIBS)
++ $1_LIBS=`$PKG_CONFIG --libs "$2"`
++ AC_MSG_RESULT($$1_LIBS)
++ else
++ $1_CFLAGS=""
++ $1_LIBS=""
++ ## If we have a custom action on failure, don't print errors, but
++ ## do set a variable so people can do so.
++ $1_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
++ ifelse([$4], ,echo $$1_PKG_ERRORS,)
++ fi
++
++ AC_SUBST($1_CFLAGS)
++ AC_SUBST($1_LIBS)
++ else
++ echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
++ echo "*** See http://www.freedesktop.org/software/pkgconfig"
++ fi
++ fi
++
++ if test $succeeded = yes; then
++ ifelse([$3], , :, [$3])
++ else
++ ifelse([$4], , AC_MSG_ERROR([Library requirements ($2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.]), [$4])
++ fi
++])
++
++