summaryrefslogtreecommitdiff
path: root/packages/xaos/xaos_3.2.3.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2007-01-28 16:14:43 +0000
committerPhil Blundell <philb@gnu.org>2007-01-28 16:14:43 +0000
commit25fd37ef987368dd32eba359273c5af98158a364 (patch)
tree5f2320dd99ebfb6fd219bd57a9395ebddeee6537 /packages/xaos/xaos_3.2.3.bb
parentb099d3ec077475cf9e24c271fdbd4c1ddbbb70b1 (diff)
parent6baa6c1f96b3137abdaf5d50af955115844197ae (diff)
merge of '7a32604865cb7ad63fbc7f14acda9e02229b44b5'
and '9ab9482d0ea26dbc9267d10e1eb42cc1a7546b6b'
Diffstat (limited to 'packages/xaos/xaos_3.2.3.bb')
-rw-r--r--packages/xaos/xaos_3.2.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/xaos/xaos_3.2.3.bb b/packages/xaos/xaos_3.2.3.bb
new file mode 100644
index 0000000000..22cedeb296
--- /dev/null
+++ b/packages/xaos/xaos_3.2.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNU XaoS, a realtime fractal generator zoomer"
+HOMEPAGE = "http://wmi.math.u-szeged.hu/xaos/doku.php"
+SECTION = "graphics"
+LICENSE = "GPLv2"
+DEPENDS = "aalib libx11 zlib libpng"
+RDEPENDS += "libxxf86dga"
+PR = "r0"
+
+SRC_URI = "http://easynews.dl.sourceforge.net/sourceforge/xaos/XaoS-3.2.3.tar.gz \
+ file://fix-build.patch;patch=1 \
+ file://fix-aalib-configure.patch;patch=1"
+
+S = "${WORKDIR}/XaoS-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-nls"
+#--with-x --with-ncurses=${STAGING_INCDIR} --with-dga-driver=no --with-x11-driver=no --with-aa-driver=yes
+
+do_configure_prepend() {
+ sed -i 's~/usr/include~${STAGING_INCDIR}~' ${S}/configure.in
+ sed -i 's~/usr/local/include~${STAGING_INCDIR}~' ${S}/configure.in
+ sed -i 's~/usr/lib~${STAGING_LIBDIR}~' ${S}/configure.in
+ sed -i 's~/usr/local/lib~${STAGING_LIBDIR}~' ${S}/configure.in
+}
+
+FILES_${PN} = "${bindir} ${datadir}/XaoS/catalogs"
+
+CFLAGS = "-L${STAGING_LIBDIR}"