summaryrefslogtreecommitdiff
path: root/packages/wlan-ng/wlan-ng-modules-0.2.2
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-05 17:58:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-05 17:58:34 +0000
commitb2751bb5a7fcf03ae0e48929ebcac1996fd74ee4 (patch)
tree7852bfb3b00263c7997a5db5860d9d91dbad11d7 /packages/wlan-ng/wlan-ng-modules-0.2.2
parenta7e0429eeb5117c75fff0e2da0e07bc1a89f0dfc (diff)
wlan-ng: add modules and userland utilities 0.2.2 (final)
Diffstat (limited to 'packages/wlan-ng/wlan-ng-modules-0.2.2')
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.2/.mtn2git_empty0
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.2/compile-fix-HACK.patch43
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.2/config.in21
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.2/no-compat.patch47
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.2/only-the-modules.patch31
5 files changed, 142 insertions, 0 deletions
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.2/.mtn2git_empty b/packages/wlan-ng/wlan-ng-modules-0.2.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.2/.mtn2git_empty
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.2/compile-fix-HACK.patch b/packages/wlan-ng/wlan-ng-modules-0.2.2/compile-fix-HACK.patch
new file mode 100644
index 0000000000..a8182076d7
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.2/compile-fix-HACK.patch
@@ -0,0 +1,43 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.2/src/prism2/driver/prism2_cs.c~compile-fix-HACK.patch
++++ linux-wlan-ng-0.2.2/src/prism2/driver/prism2_cs.c
+@@ -21,15 +21,6 @@
+ * is set to and what the CIS
+ * says.
+ */
+-#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,11) )
+-#if (LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,5))
+-static int numlist = 4;
+-module_param_array(irq_list, int, numlist, 0444);
+-#else
+-module_param_array(irq_list, int, NULL, 0444);
+-#endif
+-module_param( irq_mask, int, 0644);
+-#endif
+
+ static dev_link_t *dev_list = NULL; /* head of instance list */
+
+--- linux-wlan-ng-0.2.2/src/prism2/driver/hfa384x_usb.c~compile-fix-HACK.patch
++++ linux-wlan-ng-0.2.2/src/prism2/driver/hfa384x_usb.c
+@@ -3240,7 +3240,7 @@
+ int result;
+ DBFENTER;
+
+- might_sleep();
++ might_sleep(0);
+
+ if (usb_clear_halt(hw->usb, hw->endp_in)) {
+ WLAN_LOG_ERROR(
+@@ -3316,7 +3316,7 @@
+ int i;
+ DBFENTER;
+
+- might_sleep();
++ might_sleep(0);
+
+ /* There's no need for spinlocks here. The USB "disconnect"
+ * function sets this "removed" flag and then calls us.
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.2/config.in b/packages/wlan-ng/wlan-ng-modules-0.2.2/config.in
new file mode 100644
index 0000000000..5b9b7c780c
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.2/config.in
@@ -0,0 +1,21 @@
+WLAN_VERSION=0
+WLAN_PATCHLEVEL=2
+WLAN_SUBLEVEL=1
+WLAN_EXTRAVERSION=-pre26
+#LINUX_SRC=$(KERNEL_SOURCE)
+PCMCIA_SRC=
+PREFIX=
+INST_EXEDIR=/sbin
+#TARGET_ROOT_ON_HOST=
+#RC_DIR=/etc/init.d
+PCMCIA_DIR=/etc/pcmcia
+SYSV_INIT=y
+INSTALL_DEPMOD=
+WLAN_DEBUG=n
+CROSS_COMPILE_ENABLED=n
+CROSS_COMPILE=
+HOST_COMPILE=
+PRISM2_PLX=y
+PRISM2_PCMCIA=y
+PRISM2_PCI=y
+PRISM2_USB=y
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.2/no-compat.patch b/packages/wlan-ng/wlan-ng-modules-0.2.2/no-compat.patch
new file mode 100644
index 0000000000..4f59f0fa5d
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.2/no-compat.patch
@@ -0,0 +1,47 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.1pre21/src/include/wlan/wlan_compat.h~no-compat
++++ linux-wlan-ng-0.2.1pre21/src/include/wlan/wlan_compat.h
+@@ -351,14 +351,14 @@
+
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,4,20))
+ #ifdef _LINUX_LIST_H
+-
++/*
+ static inline void list_move_tail(struct list_head *list,
+ struct list_head *head)
+ {
+ __list_del(list->prev, list->next);
+ list_add_tail(list, head);
+ }
+-
++*/
+ static inline void __list_splice(struct list_head *list,
+ struct list_head *head)
+ {
+@@ -372,13 +372,13 @@
+ last->next = at;
+ at->prev = last;
+ }
+-
++/*
+ static inline void list_move(struct list_head *list, struct list_head *head)
+ {
+ __list_del(list->prev, list->next);
+ list_add(list, head);
+ }
+-
++*/
+ static inline void list_splice_init(struct list_head *list,
+ struct list_head *head)
+ {
+@@ -388,7 +388,6 @@
+ }
+ }
+
+-
+ #endif // LIST_H
+ #endif
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.2/only-the-modules.patch b/packages/wlan-ng/wlan-ng-modules-0.2.2/only-the-modules.patch
new file mode 100644
index 0000000000..a119460a1d
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.2/only-the-modules.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.1-pre26/src/Makefile~only-the-modules.patch
++++ linux-wlan-ng-0.2.1-pre26/src/Makefile
+@@ -44,10 +44,8 @@
+
+ include ../config.mk
+
+-DIRS=p80211 prism2 shared wlanctl wland nwepgen \
+- mkmeta wlancfg
+-ALL_DIRS=mkmeta p80211 prism2 shared wlanctl wland \
+- nwepgen wlancfg
++DIRS=p80211 prism2 shared mkmeta
++ALL_DIRS=mkmeta p80211 prism2 shared
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`
+--- linux-wlan-ng-0.2.1-pre26/src/prism2/Makefile~only-the-modules.patch
++++ linux-wlan-ng-0.2.1-pre26/src/prism2/Makefile
+@@ -44,7 +44,7 @@
+
+ include ../../config.mk
+
+-DIRS=driver ridlist download
++DIRS=driver ridlist
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`