summaryrefslogtreecommitdiff
path: root/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/wlan-ng/wlan-ng-modules-0.2.1-pre26
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/wlan-ng/wlan-ng-modules-0.2.1-pre26')
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/.mtn2git_empty0
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/no-compat.patch47
-rw-r--r--packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/only-the-modules.patch31
3 files changed, 78 insertions, 0 deletions
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/.mtn2git_empty b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/.mtn2git_empty
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/no-compat.patch b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/no-compat.patch
index e69de29bb2..4f59f0fa5d 100644
--- a/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/no-compat.patch
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/no-compat.patch
@@ -0,0 +1,47 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.1pre21/src/include/wlan/wlan_compat.h~no-compat
++++ linux-wlan-ng-0.2.1pre21/src/include/wlan/wlan_compat.h
+@@ -351,14 +351,14 @@
+
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,4,20))
+ #ifdef _LINUX_LIST_H
+-
++/*
+ static inline void list_move_tail(struct list_head *list,
+ struct list_head *head)
+ {
+ __list_del(list->prev, list->next);
+ list_add_tail(list, head);
+ }
+-
++*/
+ static inline void __list_splice(struct list_head *list,
+ struct list_head *head)
+ {
+@@ -372,13 +372,13 @@
+ last->next = at;
+ at->prev = last;
+ }
+-
++/*
+ static inline void list_move(struct list_head *list, struct list_head *head)
+ {
+ __list_del(list->prev, list->next);
+ list_add(list, head);
+ }
+-
++*/
+ static inline void list_splice_init(struct list_head *list,
+ struct list_head *head)
+ {
+@@ -388,7 +388,6 @@
+ }
+ }
+
+-
+ #endif // LIST_H
+ #endif
diff --git a/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/only-the-modules.patch b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/only-the-modules.patch
index e69de29bb2..a119460a1d 100644
--- a/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/only-the-modules.patch
+++ b/packages/wlan-ng/wlan-ng-modules-0.2.1-pre26/only-the-modules.patch
@@ -0,0 +1,31 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- linux-wlan-ng-0.2.1-pre26/src/Makefile~only-the-modules.patch
++++ linux-wlan-ng-0.2.1-pre26/src/Makefile
+@@ -44,10 +44,8 @@
+
+ include ../config.mk
+
+-DIRS=p80211 prism2 shared wlanctl wland nwepgen \
+- mkmeta wlancfg
+-ALL_DIRS=mkmeta p80211 prism2 shared wlanctl wland \
+- nwepgen wlancfg
++DIRS=p80211 prism2 shared mkmeta
++ALL_DIRS=mkmeta p80211 prism2 shared
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`
+--- linux-wlan-ng-0.2.1-pre26/src/prism2/Makefile~only-the-modules.patch
++++ linux-wlan-ng-0.2.1-pre26/src/prism2/Makefile
+@@ -44,7 +44,7 @@
+
+ include ../../config.mk
+
+-DIRS=driver ridlist download
++DIRS=driver ridlist
+
+ ifneq ($(wildcard *.addon),)
+ DIRS+=`cat *.addon`