summaryrefslogtreecommitdiff
path: root/packages/wlags-modules/wlags-modules_718.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/wlags-modules/wlags-modules_718.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/wlags-modules/wlags-modules_718.inc')
-rw-r--r--packages/wlags-modules/wlags-modules_718.inc67
1 files changed, 0 insertions, 67 deletions
diff --git a/packages/wlags-modules/wlags-modules_718.inc b/packages/wlags-modules/wlags-modules_718.inc
deleted file mode 100644
index c3f49872d6..0000000000
--- a/packages/wlags-modules/wlags-modules_718.inc
+++ /dev/null
@@ -1,67 +0,0 @@
-DESCRIPTION = "A driver from Agera (a card manufacturer) for wireless LAN cards based on Hermes cards."
-HOMEPAGE = "http://www.agere.com/mobility/wireless_lan_drivers.html"
-SECTION = "kernel/modules"
-PRIORITY = "optional"
-DEPENDS = "virtual/kernel"
-LICENSE = "BSD"
-PR = "r1"
-
-TARFILE = "wl_lkm_${PV}_release.tar.gz"
-
-
-#
-# The original wlags tar file is a bit messy:
-# * it doesn't contain it's own subdirectory
-# * the files are formatted for Windows/DOS (with CR/LF)
-# * they assume that the pcmcia-cs source code is there
-# * they don't use the kernel makefile approach
-#
-# Because of this, I create the IPK in a little unusual way:
-# * I "flatten" the structure to be able to use the kernel makefile concept
-# * the patches I have are for the flattened structure
-# * then I do the usual compile/install/package dance
-#
-
-SRC_URI = "ftp://ftp.elmeg.de/artem/ClientCards/11b/linux/${TARFILE} \
- file://Makefile \
- file://includes.patch \
- file://kernel-pcmcia.patch \
- file://bugs.patch \
- file://fixes.patch \
- file://wlags_h${COMPILE_HERMES}.conf"
-S = "${WORKDIR}/${PN}"
-
-do_configure() {
- cp ../{hcf,firmware,include/hcf,include/wireless}/*.h .
- cp ../{hcf,firmware,wireless}/*.c .
- cp ../etc/wlags49.conf .
- perl -pi -e 'r:\r::g' *.h *.c
-
- patch -p1 <${WORKDIR}/includes.patch
- patch -p1 <${WORKDIR}/kernel-pcmcia.patch
- patch -p1 <${WORKDIR}/bugs.patch
- patch -p1 <${WORKDIR}/fixes.patch
- cp ${WORKDIR}/Makefile .
-}
-
-
-do_compile() {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- make -C ${STAGING_KERNEL_DIR} \
- modules \
- SUBDIRS="${S}" \
- CC="${KERNEL_CC}" LD="${KERNEL_LD}" \
- COMPILE_HERMES=${COMPILE_HERMES}
-}
-
-
-do_install() {
- install -d ${D}${sysconfdir}/pcmcia
- install -m 0644 ${WORKDIR}/wlags_h${COMPILE_HERMES}.conf ${D}${sysconfdir}/pcmcia/
-
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/wireless
- ls
- install -m 0644 wlags49_h${COMPILE_HERMES}_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/wireless
-}
-
-FILES = "/lib/modules/${KERNEL_VERSION}/net/wireless/*${KERNEL_OBJECT_SUFFIX} /${sysconfdir}"