summaryrefslogtreecommitdiff
path: root/packages/wireshark
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-02-18 00:40:37 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-02-18 00:40:37 +0000
commitc0cb44d08ae453391b643b3e458a349dc00b5a51 (patch)
tree206f7636214999888147a48c022054cc51a61d09 /packages/wireshark
parent632f5de2cc8377e4856c5062f3c7c863b090766e (diff)
tshark: initial commit of tshark, the text-based version of wireshark. closes 2283.
* the latest version 0.99.7 fails do_patch, so I left everything at 0.99.4
Diffstat (limited to 'packages/wireshark')
-rw-r--r--packages/wireshark/tshark_0.99.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/wireshark/tshark_0.99.4.bb b/packages/wireshark/tshark_0.99.4.bb
new file mode 100644
index 0000000000..4f8f6781bf
--- /dev/null
+++ b/packages/wireshark/tshark_0.99.4.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "tshark is the text based verion of wireshark - a popular network protocol analyzer"
+HOMEPAGE = "http://www.ethereal.com"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "perl-native gnutls libpcap pcre expat"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.bz2 \
+ file://use-our-lemon.patch;patch=1 \
+ file://no-host-includes.patch;patch=1"
+
+S=${WORKDIR}/wireshark-${PV}
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-wireshark"
+
+do_compile_prepend() {
+ ${BUILD_CC} ${BUILD_CFLAGS} -o rdps rdps.c
+ oe_runmake -C tools/lemon CC="${BUILD_CC} ${BUILD_CFLAGS}" LDFLAGS="${BUILD_LDFLAGS}"
+}
+