summaryrefslogtreecommitdiff
path: root/packages/webkit/webkit-gtk_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-10 15:20:06 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-10 15:20:06 +0100
commitc4191523521757d878671b5eb3bcaf474f608ad3 (patch)
tree81639068950bd7f05e509a7c3641495884170738 /packages/webkit/webkit-gtk_svn.bb
parent0f9d6fa4099d4ee7e02c170f6d6d19dbfa2a93f4 (diff)
webkit-gtk: switch to libsoup backend (segfaults are gone) to get cookies working with midori
* runtime tested on beagleboard
Diffstat (limited to 'packages/webkit/webkit-gtk_svn.bb')
-rw-r--r--packages/webkit/webkit-gtk_svn.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/packages/webkit/webkit-gtk_svn.bb b/packages/webkit/webkit-gtk_svn.bb
index 96ef562e75..98926727fe 100644
--- a/packages/webkit/webkit-gtk_svn.bb
+++ b/packages/webkit/webkit-gtk_svn.bb
@@ -1,11 +1,11 @@
DESCRIPTION = "WebKit browser engine, GTK+ edition"
-DEPENDS = "curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
+DEPENDS = "libsoup-2.4 curl icu libxml2 cairo libxslt libxt libidn gnutls gtk+ gstreamer gst-plugins-base gnome-vfs bison-native flex-native gperf-native perl-native sqlite3"
SRCREV_FORMAT = "webcore-rwebkit"
# Yes, this is wrong...
PV = "0.1+svnr${SRCREV}"
-PR = "r7"
+PR = "r8"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -14,7 +14,7 @@ SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=WebKit;proto=http;name=webkit \
svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitLibraries;proto=http \
svn://svn.webkit.org/repository/webkit/trunk/;module=WebKitTools;proto=http \
- file://acinclude.m4 \
+ svn://svn.webkit.org/repository/webkit/trunk/;module=autotools;proto=http \
file://Makefile \
file://Makefile.shared \
file://autogen.sh \
@@ -29,13 +29,13 @@ inherit autotools pkgconfig lib_package
export BISON="${STAGING_BINDIR_NATIVE}/bison"
ARM_INSTRUCTION_SET = "arm"
-# FIXME: Segfaulting without --with-http-backend=curl
EXTRA_OECONF = "\
--enable-debug=no \
--enable-svg \
--enable-icon-database=yes \
- --with-http-backend=curl \
+ --with-http-backend=soup \
"
+EXTRA_AUTORECONF = " -I autotools "
# Dolt gets used on x86 and ppc and hardcodes 'libtool'
do_configure_append() {