summaryrefslogtreecommitdiff
path: root/packages/webkit/webkit-gtk/configure.ac
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-09-03 12:50:58 +0000
committerStanislav Brabec <utx@penguin.cz>2008-09-03 12:50:58 +0000
commit834d6f6f90bfaae37931d9ebbc2bde7a0e567521 (patch)
tree597e3780a0809bb9870cd8ec51b09b810d4ef603 /packages/webkit/webkit-gtk/configure.ac
parente6d60a638dbeeff8d57561a31d6a6bc0c0c729ea (diff)
webkit-gtk updated from snapshot 35533 to snapshot 35977:
* seems to be more stable than previous * requires latest bison to compile * http soup backend seems to be broken, stay at curl backend
Diffstat (limited to 'packages/webkit/webkit-gtk/configure.ac')
-rw-r--r--packages/webkit/webkit-gtk/configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/webkit/webkit-gtk/configure.ac b/packages/webkit/webkit-gtk/configure.ac
index 768ae9f9f2..21f72661ec 100644
--- a/packages/webkit/webkit-gtk/configure.ac
+++ b/packages/webkit/webkit-gtk/configure.ac
@@ -95,6 +95,10 @@ fi
AC_PATH_PROG(FLEX, flex)
if test -z "$FLEX"; then
AC_MSG_ERROR([You need the 'flex' lexer generator to compile WebKit])
+else
+ FLEX_VERSION=`$FLEX --version | sed 's,.*\ \([0-9]*\.[0-9]*\.[0-9]*\)$,\1,'`
+ AX_COMPARE_VERSION([2.5.33],[gt],[$FLEX_VERSION],
+ AC_MSG_WARN([You need at least version 2.5.33 of the 'flex' lexer generator to compile WebKit correctly]))
fi
AC_PATH_PROG(GPERF, gperf)
@@ -284,6 +288,26 @@ PKG_CHECK_MODULES([WEBKITDEPS],
AC_SUBST([WEBKITDEPS_CFLAGS])
AC_SUBST([WEBKITDEPS_LIBS])
+# check for Xt if the target is X11
+if test "$with_target" = "x11"; then
+ PKG_CHECK_MODULES([XT],
+ [xt],
+ [xt_has_pkg_config=yes],
+ [xt_has_pkg_config=no])
+ # some old versions of Xt do not provide xt.pc, so try to link against Xt
+ # and if it's installed fall back to just adding -lXt
+ if test "$xt_has_pkg_config" = "no"; then
+ # using AC_CHECK_LIB instead of AC_SEARCH_LIB is fine in this case as
+ # we don't care about the XtOpenDisplay symbol but only about the
+ # existence of libXt
+ AC_CHECK_LIB([Xt], [XtOpenDisplay],
+ [XT_CFLAGS=""; XT_LIBS="-lXt"],
+ [AC_MSG_ERROR([X Toolkit Intrinsics library (libXt) not found])])
+ fi
+ AC_SUBST([XT_CFLAGS])
+ AC_SUBST([XT_LIBS])
+fi
+
# check whether to build with debugging enabled
AC_MSG_CHECKING([whether to do a debug build])
AC_ARG_ENABLE(debug,