summaryrefslogtreecommitdiff
path: root/packages/vte/files
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-03-07 13:05:07 +0000
committerJohn Lee <john_lee@openmoko.org>2008-03-07 13:05:07 +0000
commit0b098d35b319ed6c00f363cb0d4fd447d7fb8d57 (patch)
treea830bf983a66688f5648cd83e362c4fea2f48f6b /packages/vte/files
parent06fb90eb31b0b85a5c5c7adf185ce2515c5b1220 (diff)
parentd3bbd28f22fbd8e9d097081fa128ae18197f36e1 (diff)
merge of '26501141207c84e31e0f43c5795a15c0f16dbce5'
and '86618f966282489d43b51fbf0ee93b954ac615ae'
Diffstat (limited to 'packages/vte/files')
-rw-r--r--packages/vte/files/.mtn2git_empty0
-rw-r--r--packages/vte/files/vte-pkgconfig-fixes.patch47
2 files changed, 47 insertions, 0 deletions
diff --git a/packages/vte/files/.mtn2git_empty b/packages/vte/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/vte/files/.mtn2git_empty
diff --git a/packages/vte/files/vte-pkgconfig-fixes.patch b/packages/vte/files/vte-pkgconfig-fixes.patch
new file mode 100644
index 0000000000..2acc7348e7
--- /dev/null
+++ b/packages/vte/files/vte-pkgconfig-fixes.patch
@@ -0,0 +1,47 @@
+Index: vte-0.16.9/configure.in
+===================================================================
+--- vte-0.16.9.orig/configure.in 2007-09-17 23:07:18.000000000 +0100
++++ vte-0.16.9/configure.in 2008-03-05 15:59:04.000000000 +0000
+@@ -381,8 +381,6 @@
+
+ # Search for the required modules.
+ PKG_CHECK_MODULES(VTE,[$wantedmodules])
+-NEEDEDPACKAGES="$wantedmodules"
+-AC_SUBST(NEEDEDPACKAGES)
+
+ # Check for various optional functions within those modules
+ save_CFLAGS="$CFLAGS"
+@@ -403,10 +401,12 @@
+
+ # Require Freetype2. First see if there is suitable pkgconfig file...
+ PKG_CHECK_EXISTS(freetype2 >= 6.1.0,
+- [PKG_CHECK_MODULES(FT2, freetype2)], [
++ [PKG_CHECK_MODULES(FT2, freetype2)
++ wantedmodules="$wantedmodules freetype2 >= 6.1.0"], [
+ # We use our local copy of the macro because packages of
+ # freetype's development files don't always include the proper macro.
+- VTE_CHECK_FT2(6.1.0,,
++ VTE_CHECK_FT2(6.1.0,[
++ wantedmodules="$wantedmodules freetype2 >= 6.1.0" ],
+ [AC_MSG_ERROR([You must have freetype 2.0.2 or later to build vte.])])])
+
+ # Temporarily pull in the Freetype cflags and libs for checking what's
+@@ -508,6 +508,8 @@
+ CFLAGS="$savecflags"
+ CPPFLAGS="$savecppflags"
+
++NEEDEDPACKAGES="$wantedmodules"
++AC_SUBST(NEEDEDPACKAGES)
+
+ wcs_funcs_includes="
+ #ifdef HAVE_STRING_H
+Index: vte-0.16.9/vte.pc.in
+===================================================================
+--- vte-0.16.9.orig/vte.pc.in 2007-02-26 21:05:19.000000000 +0000
++++ vte-0.16.9/vte.pc.in 2008-03-05 15:56:37.000000000 +0000
+@@ -11,4 +11,4 @@
+ Requires: @NEEDEDPACKAGES@
+ Libs: -L${libdir} -lvte @OTHERLIBS@
+ Libs.private: @FT2_LIBS@
+-Cflags: -I${includedir} @FT2_CFLAGS@ @OTHERCFLAGS@
++Cflags: -I${includedir} @OTHERCFLAGS@