summaryrefslogtreecommitdiff
path: root/packages/vsftpd/vsftpd_2.0.5.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-09-11 08:26:14 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2006-09-11 08:26:14 +0000
commit0c258a70cbf9c572b79bdef3b629feb2fe539751 (patch)
treea663df2f9f56be95526a3c85495fc4b39c103dfe /packages/vsftpd/vsftpd_2.0.5.bb
parent43965e79f2241e65f7d1386896d119c54d5ba72d (diff)
vsftpd: Upstream upgrade to 2.0.5. Remove old versions
Diffstat (limited to 'packages/vsftpd/vsftpd_2.0.5.bb')
-rw-r--r--packages/vsftpd/vsftpd_2.0.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/vsftpd/vsftpd_2.0.5.bb b/packages/vsftpd/vsftpd_2.0.5.bb
new file mode 100644
index 0000000000..9594fbfc0e
--- /dev/null
+++ b/packages/vsftpd/vsftpd_2.0.5.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "Secure ftp daemon"
+SECTION = "console/network"
+MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+LICENSE = "GPL"
+DEPENDS = "openssl"
+PR = "r0"
+
+SRC_URI = "ftp://vsftpd.beasts.org/users/cevans/vsftpd-${PV}.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://nopam.patch;patch=1 \
+ file://init \
+ file://vsftpd.conf"
+
+inherit update-rc.d
+
+do_configure() {
+ # Fix hardcoded /usr, /etc, /var mess.
+ cat tunables.c|sed s:\"/usr:\"${prefix}:g|sed s:\"/var:\"${localstatedir}:g \
+ |sed s:\"${prefix}/share/empty:\"${localstatedir}/share/empty:g |sed s:\"/etc:\"${sysconfdir}:g > tunables.c.new
+ mv tunables.c.new tunables.c
+}
+
+do_compile() {
+ oe_runmake "LIBS=-lssl -lcrypto -lcrypt -L${STAGING_LIBDIR}"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${mandir}/man8
+ install -d ${D}${mandir}/man5
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/vsftpd.conf ${D}${sysconfdir}/vsftpd.conf
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vsftpd
+}
+
+pkg_postinst() {
+ addgroup ftp
+ adduser --system --home /var/tmp/ftp --no-create-home --ingroup ftp --disabled-password -s /bin/false ftp
+ mkdir -p ${localstatedir}/share/empty
+}
+
+INITSCRIPT_NAME = "vsftpd"
+
+INITSCRIPT_PARAMS = "defaults"