summaryrefslogtreecommitdiff
path: root/packages/vim/vim_6.4.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-10-31 22:12:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-31 22:12:54 +0000
commite4223fb92daa8103e0da135aa2dabff4469935f7 (patch)
tree0ecb6933827edf89538de6578eec819bdfabea8b /packages/vim/vim_6.4.bb
parent48eae77b77b8f0bb236036dacb80562bd7a16bf6 (diff)
vim: added 6.4
Diffstat (limited to 'packages/vim/vim_6.4.bb')
-rw-r--r--packages/vim/vim_6.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/vim/vim_6.4.bb b/packages/vim/vim_6.4.bb
new file mode 100644
index 0000000000..1740a465a3
--- /dev/null
+++ b/packages/vim/vim_6.4.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+LICENSE = "vim"
+
+SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/vim64/src"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-gui=none --disable-gtktest \
+ --disable-xim --with-features=normal \
+ --disable-gpm --without-x --disable-netbeans \
+ --with-tlib=ncurses"
+
+do_configure () {
+ rm -f auto/*
+ touch auto/config.mk
+ aclocal
+ autoconf
+ oe_runconf
+ touch auto/configure
+ touch auto/config.mk auto/config.h
+}
+
+#FILES_${PN}-doc=${datadir}/vim/vim64/doc ${mandir} ${infodir}