summaryrefslogtreecommitdiff
path: root/packages/vim/vim.inc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-10-31 22:41:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-31 22:41:11 +0000
commitef9362fe201af92671aa7550e03f2fb4fe83d5f1 (patch)
tree54c923bad5451b5fefc937501f608836d149ce94 /packages/vim/vim.inc
parente4223fb92daa8103e0da135aa2dabff4469935f7 (diff)
vim 6.4: reorganization and split into more packages
- moved common part into vim.inc - new packages: - vim-syntax with /usr/share/vim/vimXX/syntax/ (2.8M) - vim-help with "online" help (4.1M) - vim-tutor (0.6M) More work can be done on vim but this is good step.
Diffstat (limited to 'packages/vim/vim.inc')
-rw-r--r--packages/vim/vim.inc30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/vim/vim.inc b/packages/vim/vim.inc
new file mode 100644
index 0000000000..f675ce839f
--- /dev/null
+++ b/packages/vim/vim.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "Vim is an almost fully-compatible version of the Unix editor Vi."
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+LICENSE = "vim"
+
+SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2 \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/vim${VIMVER}/src"
+
+inherit autotools
+
+do_configure () {
+ rm -f auto/*
+ touch auto/config.mk
+ aclocal
+ autoconf
+ oe_runconf
+ touch auto/configure
+ touch auto/config.mk auto/config.h
+}
+
+PACKAGES =+ "vim-common vim-syntax vim-help vim-tutor"
+FILES_vim-syntax = "${datadir}/vim/vim${VIMVER}/syntax"
+FILES_vim-help = "${datadir}/vim/vim${VIMVER}/doc"
+FILES_vim-tutor = "${datadir}/vim/vim${VIMVER}/tutor ${bindir}/vimtutor"
+
+#FILES_${PN} = "${bindir} ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+# ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+# /bin /sbin /lib/*/ /lib/*.so* ${datadir}/vim"