summaryrefslogtreecommitdiff
path: root/packages/usrp/usrp_0.8.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-21 14:18:55 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-21 14:18:55 +0000
commita061461970fc229342633011d6ea926e69470d8a (patch)
treefb10c7aabac3dd17d2c2975ca68a8f3974fa4e57 /packages/usrp/usrp_0.8.bb
parent38d0eb00876775afecaf669d3253e89011b3dfd4 (diff)
add usrp - Support software for the Universal Software Radio Peripheral (USRP)
Patch courtesy Philip Balister
Diffstat (limited to 'packages/usrp/usrp_0.8.bb')
-rw-r--r--packages/usrp/usrp_0.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/usrp/usrp_0.8.bb b/packages/usrp/usrp_0.8.bb
new file mode 100644
index 0000000000..1b9966f1ce
--- /dev/null
+++ b/packages/usrp/usrp_0.8.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
+LICENSE = "GPL"
+MAINTAINER = "Philip Balister philip@balister.org"
+HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
+SECTION = "devel"
+DEPENDS = "swig-native sdcc-native libusb"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
+ file://usb11.patch;patch=1"
+S = "${WORKDIR}/usrp-${PV}"
+
+inherit autotools
+
+do_stage () {
+ oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
+
+ install -m 644 host/lib/usrp0.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_daughterboards.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
+
+ install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
+}
+
+PACKAGES += "python-pyursp"
+FILES_python-pyursp = "${libdir}/python*"