summaryrefslogtreecommitdiff
path: root/packages/usrp/usrp_0.8.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-07-21 16:42:58 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-21 16:42:58 +0000
commite40c5b40e67325fd054d160367f0d52c4bfc91b9 (patch)
tree323270453f8d6bb3c0cb1cf561664f1a7d534dca /packages/usrp/usrp_0.8.bb
parent679c90c88802a0651613c842d1d89ae55f2b72d4 (diff)
parent17ab5f4762a3d2ecbcc7d086be47a10b7c9de7dd (diff)
merge of 1128356cf74edd3dc9e128ad1f830a989faf8e2f
and a8d45d0b05a8392ab241eca4deab7c8bc83b0a2d
Diffstat (limited to 'packages/usrp/usrp_0.8.bb')
-rw-r--r--packages/usrp/usrp_0.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/usrp/usrp_0.8.bb b/packages/usrp/usrp_0.8.bb
new file mode 100644
index 0000000000..1b9966f1ce
--- /dev/null
+++ b/packages/usrp/usrp_0.8.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
+LICENSE = "GPL"
+MAINTAINER = "Philip Balister philip@balister.org"
+HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
+SECTION = "devel"
+DEPENDS = "swig-native sdcc-native libusb"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
+ file://usb11.patch;patch=1"
+S = "${WORKDIR}/usrp-${PV}"
+
+inherit autotools
+
+do_stage () {
+ oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
+
+ install -m 644 host/lib/usrp0.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_daughterboards.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
+
+ install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
+}
+
+PACKAGES += "python-pyursp"
+FILES_python-pyursp = "${libdir}/python*"