summaryrefslogtreecommitdiff
path: root/packages/usrp/usrp_0.12.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2006-10-19 19:17:41 +0000
committerPhilip Balister <philip@balister.org>2006-10-19 19:17:41 +0000
commitc6d2b76c9ce1609f1e7be9546fd2d0031447251e (patch)
tree85712b64aa89437cc7e6a521cfded91aeaa302f7 /packages/usrp/usrp_0.12.bb
parent2a707b232b5a65e7c7a76649f90c1390e438da60 (diff)
usrp : Update bb file to use 0.12 version. Start fixing build process.
Diffstat (limited to 'packages/usrp/usrp_0.12.bb')
-rw-r--r--packages/usrp/usrp_0.12.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/usrp/usrp_0.12.bb b/packages/usrp/usrp_0.12.bb
new file mode 100644
index 0000000000..a057eb2e4c
--- /dev/null
+++ b/packages/usrp/usrp_0.12.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Support software for the Universal Software Radio Peripheral (USRP)"
+LICENSE = "GPL"
+HOMEPAGE = "http://comsec.com/wiki?UniversalSoftwareRadioPeripheral"
+SECTION = "devel"
+DEPENDS = "swig-native sdcc-native libusb python python-native"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.gnu.org/gnu/gnuradio/usrp-${PV}.tar.gz \
+ file://usb11.patch;patch=1"
+S = "${WORKDIR}/usrp-${PV}"
+
+inherit autotools pkgconfig
+
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
+
+do_stage () {
+ oe_libinstall -so -C host/lib/.libs/ libusrp ${STAGING_LIBDIR}
+
+ install -m 644 host/lib/usrp0.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_basic.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_bytesex.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_config.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_daughterboards.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_prims.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_slots.h ${STAGING_INCDIR}
+ install -m 644 host/lib/usrp_standard.h ${STAGING_INCDIR}
+
+ install -m 644 firmware/include/usrp_i2c_addr.h ${STAGING_INCDIR}
+}
+
+PACKAGES += "python-pyursp"
+FILES_python-pyursp = "${libdir}/python*"